netdev
[Top] [All Lists]

Re: 2.6.8.1 IPv6 Routing Problem

To: davem@xxxxxxxxxxxxx
Subject: Re: 2.6.8.1 IPv6 Routing Problem
From: YOSHIFUJI Hideaki / 吉藤英明 <yoshfuji@xxxxxxxxxxxxxx>
Date: Sun, 19 Sep 2004 11:20:09 +0900 (JST)
Cc: laforge@xxxxxxxxxxxx, netdev@xxxxxxxxxxx, usagi-users@xxxxxxxxxxxxxx, yoshfuji@xxxxxxxxxxxxxx
In-reply-to: <20040919.111141.42341294.yoshfuji@xxxxxxxxxxxxxx>
Organization: USAGI Project
References: <20040918220211.GI6005@xxxxxxxxxxxxxxxxxxxxxxx> <20040918180647.6be57884.davem@xxxxxxxxxxxxx> <20040919.111141.42341294.yoshfuji@xxxxxxxxxxxxxx>
Sender: netdev-bounce@xxxxxxxxxxx
In article <20040919.111141.42341294.yoshfuji@xxxxxxxxxxxxxx> (at Sun, 19 Sep 
2004 11:11:41 +0900 (JST)), YOSHIFUJI Hideaki / 吉藤英明 <yoshfuji@xxxxxxxxxxxxxx> 
says:

> In article <20040918180647.6be57884.davem@xxxxxxxxxxxxx> (at Sat, 18 Sep 2004 
> 18:06:47 -0700), "David S. Miller" <davem@xxxxxxxxxxxxx> says:
> 
> > On Sun, 19 Sep 2004 00:02:11 +0200
> > Harald Welte <laforge@xxxxxxxxxxxx> wrote:
> > 
> > > Now I'm stuck with another issue:  The interfaces suddenly no logner
> > > get any link-local addresses:
> > 
> > Probably due to this change.
> > 
> > # This is a BitKeeper generated diff -Nru style patch.
> > #
> > # ChangeSet
> > #   2004/09/10 14:50:26-07:00 yoshfuji@xxxxxxxxxxxxxx 
> > #   [IPV6]: Deprecate all-on-link assumption
> 
> I don't think so.

And, that code was run after the link-local address assignment.
What we did was:

 1. Try to assign link-local address.
    - start DAD
    - wait a while
 2. If DAD ends with no duplicated addresses, 
    try to search neighbor routers.
    - send RS
    - wait a while
 3. If no routers present, add "all-on-link" route.

The patch deletes the last one (3).
and it should not be something to do with the link-local address assignment.

--yoshfuji

<Prev in Thread] Current Thread [Next in Thread>