Search String: Display: Description: Sort:

Results:

References: [ +subject:/^(?:^\s*(re|sv|fwd|fw)[\[\]\d]*[:>-]+\s*)*\[PATCH\s+7\/9\]\s+xfs\:\s+clean\s+up\s+xfs_ioerror_alert\s*$/: 4 ]

Total 4 documents matching your query.

1. [PATCH 7/9] xfs: clean up xfs_ioerror_alert (score: 1)
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Thu, 06 Oct 2011 17:06:14 -0400
Instead of passing the block number and mount structure explicitly get them off the bp and fix make the argument order more natural. Also move it to xfs_buf.c and stop printing the device name given
/archives/xfs/2011-10/msg00096.html (20,476 bytes)

2. Re: [PATCH 7/9] xfs: clean up xfs_ioerror_alert (score: 1)
Author: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Fri, 7 Oct 2011 12:54:41 +1100
Only thing I'm wondering about is whether is should be renamed xfs_buf_ioerror_alert(), now that it really is a xfs_buf specific function? Also, many of the callers could probably pass __func__ rathe
/archives/xfs/2011-10/msg00114.html (9,086 bytes)

3. Re: [PATCH 7/9] xfs: clean up xfs_ioerror_alert (score: 1)
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Fri, 7 Oct 2011 10:17:59 -0400
That probably is a better name. There are a few other functions in the buffer code that are misnamed like that e.g. xfs_incore and to a lesser extent xfs_bwrite or XFS_bflush. True.
/archives/xfs/2011-10/msg00120.html (9,242 bytes)

4. Re: [PATCH 7/9] xfs: clean up xfs_ioerror_alert (score: 1)
Author: Alex Elder <aelder@xxxxxxx>
Date: Fri, 7 Oct 2011 14:37:16 -0500
I agree on the name change suggestion, possibly to xfs_buf_error_alert(). Also, with just one exception it seems that the "func" argument is simply the name of the calling function. I would favor add
/archives/xfs/2011-10/msg00128.html (9,687 bytes)


This search system is powered by Namazu