Search String: Display: Description: Sort:

Results:

References: [ +subject:/^(?:^\s*(re|sv|fwd|fw)[\[\]\d]*[:>-]+\s*)*\[PATCH\]\s+small\s+skbuff\.\[ch\]\s+tweaks\s*$/: 10 ]

Total 10 documents matching your query.

1. [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Mitchell Blank Jr <mitch@xxxxxxxxxx>
Date: Tue, 2 Sep 2003 01:16:25 -0700
This patch: o Makes a couple inline functions in <linux/skbuff.h> take const arguments as appropriate o Obvious unlikely()/likely()/BUG_ON() conversions Patch is versus 2.6.0-test4. -Mitch -- linux-2
/archives/netdev/2003-09/msg00036.html (17,383 bytes)

2. Re: [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Mitchell Blank Jr <mitch@xxxxxxxxxx>
Date: Tue, 2 Sep 2003 02:10:59 -0700
Is there any disadvantage to stating it explicitly? -Mitch
/archives/netdev/2003-09/msg00037.html (7,786 bytes)

3. Re: [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Andi Kleen <ak@xxxxxxx>
Date: Tue, 2 Sep 2003 11:04:23 +0200
It makes the code much uglier. -Andi
/archives/netdev/2003-09/msg00038.html (7,996 bytes)

4. Re: [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Andi Kleen <ak@xxxxxxx>
Date: Tue, 2 Sep 2003 10:58:33 +0200
Both unlikely(!ptr) and likely(ptr) are not needed because gcc assumes this by default -Andi
/archives/netdev/2003-09/msg00039.html (8,412 bytes)

5. Re: [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Mitchell Blank Jr <mitch@xxxxxxxxxx>
Date: Tue, 2 Sep 2003 02:49:42 -0700
Well I guess it's a matter of taste then. Personally I like unlikely()/ likely() a lot, even from just a readability standpoint. I think it provides a nice hint to the structure of code while reading
/archives/netdev/2003-09/msg00040.html (8,843 bytes)

6. [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Mitchell Blank Jr <mitch@xxxxxxxxxx>
Date: Tue, 2 Sep 2003 01:16:25 -0700
This patch: o Makes a couple inline functions in <linux/skbuff.h> take const arguments as appropriate o Obvious unlikely()/likely()/BUG_ON() conversions Patch is versus 2.6.0-test4. -Mitch -- linux-2
/archives/netdev/2003-09/msg00965.html (17,383 bytes)

7. Re: [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Mitchell Blank Jr <mitch@xxxxxxxxxx>
Date: Tue, 2 Sep 2003 02:10:59 -0700
Is there any disadvantage to stating it explicitly? -Mitch
/archives/netdev/2003-09/msg00966.html (7,884 bytes)

8. Re: [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Andi Kleen <ak@xxxxxxx>
Date: Tue, 2 Sep 2003 11:04:23 +0200
It makes the code much uglier. -Andi
/archives/netdev/2003-09/msg00967.html (8,120 bytes)

9. Re: [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Andi Kleen <ak@xxxxxxx>
Date: Tue, 2 Sep 2003 10:58:33 +0200
Both unlikely(!ptr) and likely(ptr) are not needed because gcc assumes this by default -Andi
/archives/netdev/2003-09/msg00968.html (8,472 bytes)

10. Re: [PATCH] small skbuff.[ch] tweaks (score: 1)
Author: Mitchell Blank Jr <mitch@xxxxxxxxxx>
Date: Tue, 2 Sep 2003 02:49:42 -0700
Well I guess it's a matter of taste then. Personally I like unlikely()/ likely() a lot, even from just a readability standpoint. I think it provides a nice hint to the structure of code while reading
/archives/netdev/2003-09/msg00969.html (8,995 bytes)


This search system is powered by Namazu