xfs
[Top] [All Lists]

[Bug 235] New: Incorrect configure.in scripts in ALL XFS Linux packages

To: xfs-master@xxxxxxxxxxx
Subject: [Bug 235] New: Incorrect configure.in scripts in ALL XFS Linux packages
From: bugzilla-daemon@xxxxxxxxxxx
Date: Thu, 10 Apr 2003 11:53:37 -0700
Sender: linux-xfs-bounce@xxxxxxxxxxx
http://oss.sgi.com/bugzilla/show_bug.cgi?id=235

           Summary: Incorrect configure.in scripts in ALL XFS Linux packages
           Product: Linux XFS
           Version: 1.1.x
          Platform: IA32
        OS/Version: Linux
            Status: NEW
          Severity: minor
          Priority: Low
         Component: xfsprogs
        AssignedTo: xfs-master@xxxxxxxxxxx
        ReportedBy: mej@xxxxxxxxx


If this is a userspace bug, what version of the package are you using:
XFS Release 1.1 SRPM's

What kernel are you using:
Doesn't matter

Where did the XFS code come from?  (CVS, Linus, your distribution, etc):
SGI SRPM's

Description of Problem:
You have a bug in your configure.in scripts.  This bug also exists in the
Release 1.2 SRPM's, as well as the source tarballs for each release.

test -z "$MAKE" && AC_PATH_PROG(MAKE, make, /usr/bin/make)

This will not work as you think it will.  AC_PATH_PROG is not a self-contained
macro.  If you try MAKE=make rpm --rebuild attr-2.0.7-0.src.rpm, the build will
error out saying "gcc: default: No such file or directory"

Applying this patch (-p1) to configure.in and re-running autoconf will fix the 
bug:

--------------------------------------------------------------------
--- attr-2.0.7/configure.in     Mon Apr 15 10:08:48 2002
+++ mezzanine_patched_attr-2.0.7/configure.in   Thu Apr 10 14:22:29 2003
@@ -49,27 +49,37 @@
 AC_SUBST(cc)
 
 dnl check if users wants their own make
-test -z "$MAKE" && AC_PATH_PROG(MAKE, make, /usr/bin/make)
+if test -z "$MAKE"; then
+    AC_PATH_PROG(MAKE, make, /usr/bin/make)
+fi
 make=$MAKE
 AC_SUBST(make)
 
 dnl check if users wants their own linker
-test -z "$LD" && AC_PATH_PROG(LD, ld, /usr/bin/ld)
+if test -z "$LD"; then
+    AC_PATH_PROG(LD, ld, /usr/bin/ld)
+fi
 ld=$LD
 AC_SUBST(ld)
 
 dnl check if the tar program is available
-test -z "$TAR" && AC_PATH_PROG(TAR, tar)
+if test -z "$TAR"; then
+    AC_PATH_PROG(TAR, tar)
+fi
 tar=$TAR
 AC_SUBST(tar)
 
 dnl check if the gzip program is available
-test -z "$ZIP" && AC_PATH_PROG(ZIP, gzip, /bin/gzip)
+if test -z "$ZIP"; then
+    AC_PATH_PROG(ZIP, gzip, /bin/gzip)
+fi
 zip=$ZIP
 AC_SUBST(zip)
 
 dnl check if the rpm program is available
-test -z "$RPM" && AC_PATH_PROG(RPM, rpm, /bin/rpm)
+if test -z "$RPM"; then
+    AC_PATH_PROG(RPM, rpm, /bin/rpm)
+fi
 rpm=$RPM
 AC_SUBST(rpm)
 
@@ -80,7 +90,9 @@
 AC_SUBST(rpm_version)
 
 dnl check if the makedepend program is available
-test -z "$MAKEDEPEND" && AC_PATH_PROG(MAKEDEPEND, makedepend, /bin/true)
+if test -z "$MAKEDEPEND"; then
+    AC_PATH_PROG(MAKEDEPEND, makedepend, /bin/true)
+fi
 makedepend=$MAKEDEPEND
 AC_SUBST(makedepend)
 
@@ -88,13 +100,19 @@
 AC_PROG_LN_S
 
 dnl check if user wants their own awk, sed and echo
-test -z "$AWK" && AC_PATH_PROG(AWK, awk, /bin/awk)
+if test -z "$AWK"; then
+    AC_PATH_PROG(AWK, awk, /bin/awk)
+fi
 awk=$AWK
 AC_SUBST(awk)
-test -z "$SED" && AC_PATH_PROG(SED, sed, /bin/sed)
+if test -z "$SED"; then
+    AC_PATH_PROG(SED, sed, /bin/sed)
+fi
 sed=$SED
 AC_SUBST(sed)
-test -z "$ECHO" && AC_PATH_PROG(ECHO, echo, /bin/echo)
+if test -z "$ECHO"; then
+    AC_PATH_PROG(ECHO, echo, /bin/echo)
+fi
 echo=$ECHO
 AC_SUBST(echo)
 
--------------------------------------------------------------------
The same patch will apply to acl, dmapi, xfsprogs, and xfsdump.  Then re-run
autoconf for each.


How Reproducible:
100%

Steps to Reproduce:
1. MAKE=make rpm --rebuild attr-2.0.7-0.src.rpm

Actual Results:
Build fails.

Expected Results:
Build doesn't fail.

Additional Information:
N/A



------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.


<Prev in Thread] Current Thread [Next in Thread>
  • [Bug 235] New: Incorrect configure.in scripts in ALL XFS Linux packages, bugzilla-daemon <=