netdev
[Top] [All Lists]

[PATCH] Fix 64bit warning for firestream

To: chas@xxxxxxxxxxxxxxxx
Subject: [PATCH] Fix 64bit warning for firestream
From: Andi Kleen <ak@xxxxxx>
Date: Sat, 17 Jul 2004 13:36:08 +0200
Cc: linux-atm-general@xxxxxxxxxxxxxxxxxxxxx, netdev@xxxxxxxxxxx
Sender: netdev-bounce@xxxxxxxxxxx
User-agent: Gnus/5.110003 (No Gnus v0.3) Emacs/21.2 (gnu/linux)
Fix obvious 64bit issue in firestream driver. I haven't tested
if it actually works on 64bit due to lack of hardware.

-Andi

diff -u linux-2.6.8rc1-amd64-pre2/drivers/atm/firestream.c-o 
linux-2.6.8rc1-amd64-pre2/drivers/atm/firestream.c
--- linux-2.6.8rc1-amd64-pre2/drivers/atm/firestream.c-o        2004-07-17 
13:26:01.000000000 +0200
+++ linux-2.6.8rc1-amd64-pre2/drivers/atm/firestream.c  2004-07-17 
13:33:49.525480904 +0200
@@ -1380,7 +1380,7 @@
 
        if (alignment <= 0x10) {
                t = kmalloc (size, flags);
-               if ((unsigned int)t & (alignment-1)) {
+               if ((unsigned long)t & (alignment-1)) {
                        printk ("Kmalloc doesn't align things correctly! %p\n", 
t);
                        kfree (t);
                        return aligned_kmalloc (size, flags, alignment * 4);


<Prev in Thread] Current Thread [Next in Thread>
  • [PATCH] Fix 64bit warning for firestream, Andi Kleen <=