netdev
[Top] [All Lists]

Re: netfilter6: ICMPv6 type 143 doesn't match

To: Patrick McHardy <kaber@xxxxxxxxx>
Subject: Re: netfilter6: ICMPv6 type 143 doesn't match
From: "David S. Miller" <davem@xxxxxxxxxxxxx>
Date: Thu, 5 May 2005 14:34:12 -0700
Cc: yasuyuki.kozakai@xxxxxxxxxxxxx, usagi-users@xxxxxxxxxxxxxx, netdev@xxxxxxxxxxx, netfilter-devel@xxxxxxxxxxxxxxxxxxx, laforge@xxxxxxxxxxxx, pb@xxxxxxxxxxxx
In-reply-to: <427A7FF5.4030900@trash.net>
References: <6050E336B1A0D7D8E70C66F3@t1mobil.muc.aerasec.de> <200412270417.iBR4HZRG021429@toshiba.co.jp> <427A79C0.4020103@trash.net> <427A7FF5.4030900@trash.net>
Sender: netdev-bounce@xxxxxxxxxxx
On Thu, 05 May 2005 22:20:05 +0200
Patrick McHardy <kaber@xxxxxxxxx> wrote:

> Patrick McHardy wrote:
> > Yasuyuki Kozakai wrote:
> > 
> >>Well, the Multicast Listener Report seems that skb->data != skb->nh.ipv6h
> >>when interface is up. But IPv6 netfilter modules assumes that
> >>skb->data == skb->nh.ipv6h like IPv4 netfilter modules.
> >>
> >>folks, is this wrong or bad asumption ? If so, I'll fix this problem in
> >>many modules as follows.
> > 
> > 
> > Sorry for getting back to this so late, I must have missed it at the
> > time. Anyway, I think it would be safer to restore netfilters assumption
> > by doing something like this patch. If everyone is fine with it I'm
> > going to add it to my pending netfilter patches for 2.6.13.
> 
> The last patch left some unreachable code.

This looks OK with me, I hope it doesn't inadvertantly break anything.

<Prev in Thread] Current Thread [Next in Thread>