Bug 236 - XFS on "/" with usrquota: gives "XFS: unknown mount option [usrquota]"
: XFS on "/" with usrquota: gives "XFS: unknown mount option [usrquota]"
Status: RESOLVED LATER
Product: XFS
Classification: Unclassified
Component: XFS kernel code
: Current
: All Linux
: enhancement
: ---
Assigned To: XFS power people
:
:
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-10 13:13 CDT by Jeffrey Hundstad
Modified: 2003-04-23 13:27 CDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey Hundstad 2003-04-10 13:13:54 CDT
XFS on "/" with usrquota in the options line of /etc/fstab causes boot messages:

XFS: unknown mount option [usrquota].
*** ERROR!  Cannot fsck root fs because it is not mounted read-only!
XFS: unknown mount option [usrquota].
mount: / not mounted already, or bad option

The kernel then fails to remount the "/" filesystem read-write.
Comment 1 Jeffrey Hundstad 2003-04-10 13:16:10 CDT
Nathon Scott has been working with me since 03/25/03 17:19.  He thinks he
understands the problem.

I noticed that there was new mount commits and I wanted to confirm that this bug
still exists.
Comment 2 Nathan Scott 2003-04-10 15:57:58 CDT
Hello,

This is not a bug, it is really a request for engineering.  The problem is
understood, and is fundamentally that you're trying to remount a filesystem
with quota enabled which previously didn't have quota enabled.  This is not
supported, and it would take a fair amount of effort to implement, which
unfortunately isn't going to be done anytime soon (I have a number of more
pressing issues to sort through, but would be prepared to assist anyone out
there who wanted to try and get this to work...).

From xfsprogs/doc/README.quota, on mounting root filesystems with quota:
         ...
     o   Turning on quotas on the root filesystem is slightly different
         from the above.  In more recent versions of XFS, the quota mount
         flags must be passed in with the "rootflags=" boot parameter.
         In older versions of XFS and (quota-tools) quotaon(8) must be
         used on the root XFS filesystem first; and quotas will be turned
         on the next time the system is rebooted.
         ...

It has been this way for several months, although only recently have we
changed the mount option parsing code to not allow quota options to be
passed in (incorrectly) on remount when they were not specified at mount
time originally.

cheers.
Comment 3 Jeffrey Hundstad 2003-04-23 11:27:54 CDT
I've gotten some time to try the suggestions from nathans@sgi.com.  When I
booted with the flags suggested in the FAQ my machine would hang on the mount
step of the boot.  I was able to solve this by passing more info. to the kernel
during boot.  This is the line I used in my lilo.conf file:

append="rootflags=usrquota,grpquota ro"

The "ro" bit startes the filesystem as read-only, which is expected during the
standard Linux boot sequence.

I'd suggest that the append line above be added to xfsprogs/doc/README.quota and
placed into the FAQ quota section.

Thanks!