Bug 204 - directory /var/run got corrupted, got error -990 when trying to add a file
: directory /var/run got corrupted, got error -990 when trying to add a file
Status: RESOLVED DUPLICATE of bug 197
Product: XFS
Classification: Unclassified
Component: XFS kernel code
: 1.2.x
: Linux
: major
: ---
Assigned To: XFS power people
:
:
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-02 11:07 CST by Tim Engler
Modified: 2003-01-06 15:49 CST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Engler 2003-01-02 11:07:58 CST
If this is a userspace bug, what version of the package are you using:

What kernel are you using: 2.20

Where did the XFS code come from?  (CVS, Linus, your distribution, etc):

CVS patch on XFS website

Description of Problem:

Suddenly, /var/run got corrupted and nothing was able to write to this
directory. Nor was I able to remove it. xfs_repair fixed it.

How Reproducible:

I don't know.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Is 1.2 supposed to be stable enough to use?
Comment 1 Stephen Lord 2003-01-02 11:28:44 CST
Can you be a lot more specific about exactly which code you were running here,
you say CVS patch from website, but what was the date on the patch, you also
list the code you are running as 1.2 based. We have seen the same problem in
house, but it is proving difficult to track down.

XFS reports version info at startup, for instance:

SGI XFS CVS-2002-11-30_06:00_UTC with ACLs, no debug enabled
Comment 2 Tim Engler 2003-01-02 12:07:52 CST
OS is debian 3.0

XFS version is:
SGI XFS snapshot 2.4.20-2002-11-29_01:21_UTC with DMAPI, quota, no debug enabled

compiler version is:

tim@sol:~$ gcc -v
Reading specs from /usr/lib/gcc-lib/i386-linux/2.95.4/specs
gcc version 2.95.4 20011002 (Debian prerelease)

hardware is Dell Insprion 8200:

tim@sol:/usr/local/j2eetutorial/examples$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 Mobile CPU 1.60GHz
stepping        : 4
cpu MHz         : 1595.327
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 3185.04

Harddrive is:

Travelstar 40GN
Model No: IC25N040ATCS04-0
Comment 3 Bernhard Erdmann 2003-01-06 13:45:59 CST
I've observed this behaviour on a Dell Latitude C610 as well. Using
2.4.19pre3-xfs, shutdown -r now and power off when BIOS screen appears. It even
ate /etc/fstab. Seems to be related to "IDE disk does not flush write cache
before power off". I inserted hdparm -f /dev/hda into /etc/init.d/halt. As well,
I switched to 2.4.19pre4-xfs and got into the habit of shutdown -h now before
power off. Haven't observed it in the mean time again.
Comment 4 Russell Cattelan 2003-01-06 13:49:25 CST

*** This bug has been marked as a duplicate of 197 ***