xfs
[Top] [All Lists]

Re: SGI Version 1 XFS on Linux

To: "Scott, Edmund J @ SSG - Link" <edmund.scott@xxxxxxxxxx>
Subject: Re: SGI Version 1 XFS on Linux
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Thu, 7 May 2015 07:58:16 +1000
Cc: Ben Myers <bpm@xxxxxxx>, "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <2994A55DE0FBBE41B8FE47F9885D74221BC056F3@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
References: <2994A55DE0FBBE41B8FE47F9885D74221BC0569C@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> <20150506171222.GA22744@xxxxxxx> <2994A55DE0FBBE41B8FE47F9885D74221BC056F3@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Wed, May 06, 2015 at 07:47:51PM +0000, Scott, Edmund J @ SSG -
Link wrote:
> Hi,
> 
> We are in a thunderstorm right now so we had to shut down, be a
> while until we get things back up. We're in Utah with a rolling
> t-storm coming through. 
> 
> We did find documentation that XFS version 1 was pulled out of the
> linux kernel around or after kernel 2.4. and the messages kind of
> support that. I'm looking into digging up an old Red Hat OS to see
> if it is old enough to have the version 1 XFS in it.

You'd be talking about the directory version, then, not the version
of the filesystem? Irix 6.2 introduced Version 4 filesystems, but
version 2 directories didn't come along until a couple of years
later. See Slides 6-7 here:

http://events.linuxfoundation.org/sites/events/files/slides/dchinner-xfs-there-and-back.pdf

As it is, the dirv1 removal commit says "Never functioned on Linux,
just pure bloat".

http://oss.sgi.com/cgi-bin/gitweb.cgi?p=archive/xfs-import.git;a=commitdiff;h=b84149405b9c2ecbc445d2684053e4acc03342ee

So I suspect that the only way you are going to be able to read
those filesystems is with an Irix machine....

> While it was up, we've done the blkid command and it recognizes at
> least 1 partition on the SGI drive to be xfs, others were efs. We
> also used the hardware browser and got the same readings.

Yeah, that's old ;)

> We've also tried to make a disk image. If I try to mount the image
> on the linux computer, it will essentially give me the same error
> about version 1 xfs. Not that this was unexpected, it should error
> out just like the drive did. I also happen to have an O2 up and
> running, so I copied the image over to the O2 expecting to try and
> mount the image so it would/should automatically handle the xfs
> issue, but it looks like the O2 mount command does not have the
> loop or knows how to handle mounting an image like the Linux does.

http://www.nekochan.net/wiki/Loopback_Filesystems

Nekochan is the place to go for information about old SGI boxes.
It might be worth posting there to see if there is anyone local to
you with working hardware that would enable you to pull the
information off the disks....

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>