xfs
[Top] [All Lists]

Re: [RFC PATCH 1/5] new helper: iov_iter_rw()

To: David Sterba <dsterba@xxxxxxx>
Subject: Re: [RFC PATCH 1/5] new helper: iov_iter_rw()
From: Omar Sandoval <osandov@xxxxxxxxxxx>
Date: Tue, 17 Mar 2015 03:18:35 -0700
Cc: Al Viro <viro@xxxxxxxxxxxxxxxxxx>, linux-fsdevel@xxxxxxxxxxxxxxx, linux-btrfs@xxxxxxxxxxxxxxx, ceph-devel@xxxxxxxxxxxxxxx, linux-cifs@xxxxxxxxxxxxxxx, osd-dev@xxxxxxxxxxxx, linux-ext4@xxxxxxxxxxxxxxx, linux-f2fs-devel@xxxxxxxxxxxxxxxxxxxxx, fuse-devel@xxxxxxxxxxxxxxxxxxxxx, cluster-devel@xxxxxxxxxx, jfs-discussion@xxxxxxxxxxxxxxxxxxxxx, HPDD-discuss@xxxxxxxxxxx, linux-nfs@xxxxxxxxxxxxxxx, linux-nilfs@xxxxxxxxxxxxxxx, ocfs2-devel@xxxxxxxxxxxxxx, reiserfs-devel@xxxxxxxxxxxxxxx, v9fs-developer@xxxxxxxxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx, linux-kernel@xxxxxxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20150317093151.GS20767@xxxxxxxxxxxxx>
References: <cover.1426502566.git.osandov@xxxxxxxxxxx> <34dc78b262546e9343e0ed872232a97f5eaa5f15.1426502566.git.osandov@xxxxxxxxxxx> <20150316173605.GX29656@xxxxxxxxxxxxxxxxxx> <20150317093151.GS20767@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.23 (2014-03-12)
On Tue, Mar 17, 2015 at 10:31:51AM +0100, David Sterba wrote:
> On Mon, Mar 16, 2015 at 05:36:05PM +0000, Al Viro wrote:
> > On Mon, Mar 16, 2015 at 04:33:49AM -0700, Omar Sandoval wrote:
> > > Get either READ or WRITE out of iter->type.
> > 
> > Umm...  
> > 
> > > + * Get one of READ or WRITE out of iter->type without any other flags 
> > > OR'd in
> > > + * with it.
> > > + */
> > > +static inline int iov_iter_rw(const struct iov_iter *i)
> > > +{
> > > + return i->type & RW_MASK;
> > > +}
> > 
> > TBH, I would turn that into a macro.  Reason: indirect includes.
> 
> Agreed, but the proposed define is rather cryptic and I was not able to
> understand the meaning on the first glance.
> 
> > #define iov_iter_rw(i) ((0 ? (struct iov_iter *)0 : (i))->type & RW_MASK)
> 
> This worked for me, does not compile with anything else than
> 'struct iov_iter*' as i:
> 
> #define iov_iter_rw(i)        ({                      \
>       struct iov_iter __iter = *(i);          \
>       (i)->type & RW_MASK;                    \
>       })
> 
> The assignment is optimized out.

[-cc individual fs maintainers to avoid all of these email bounces,
should've looked a bit closer at that get_maintainer.pl output...]

I agree that this is a bit more readable, but it evaluates i twice.
That's an easy fix, just do __iter.type instead of (i)->type, but
there's still the possibility of someone passing in something called
__iter as i, and the fix for that tends to be "add more underscores". At
the very least, Al's macro could probably use a comment explaining
what's going on there, though.

-- 
Omar

<Prev in Thread] Current Thread [Next in Thread>