On Mon, Feb 09, 2015 at 08:35:02AM +1100, Dave Chinner wrote:
> On Fri, Feb 06, 2015 at 04:22:04PM -0600, Eric Sandeen wrote:
> > These 2 patches provide information about which filesystem
> > hit the error...
> If we are going to touch every one of these macros, then can we
> rename them to something a little shorter like XFS_CORRUPT_GOTO()
> and XFS_CORRUPT_RETURN() at the same time? That will make the code a
> little less eye-bleedy where there are lots of these statements,
> and make formatting of complex checks a bit easier, too...
XFS_CORRUPT_DOSOMETHING() jumps out to me as indicate corruption if the
logic statement evaluates as true rather than false. The latter (e.g.,
assert-like logic) is how they work today, so that could be a bit
confusing to somebody who isn't already familiar with how these macros
Unfortunately, nothing shorter than the current naming immediately comes
to mind... :/ We could kill the XFS_ prefix I suppose or even invert the
logic of the calls, but that's certainly a more significant change.
> Dave Chinner
> xfs mailing list