[Top] [All Lists]

Re: [PATCH 0/2] xfs: pass mp to XFS_WANT_CORRUPTED_*

To: Eric Sandeen <sandeen@xxxxxxxxxx>
Subject: Re: [PATCH 0/2] xfs: pass mp to XFS_WANT_CORRUPTED_*
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Mon, 9 Feb 2015 08:35:02 +1100
Cc: xfs-oss <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <54D53E8C.8070207@xxxxxxxxxx>
References: <54D53E8C.8070207@xxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Fri, Feb 06, 2015 at 04:22:04PM -0600, Eric Sandeen wrote:
> These 2 patches provide information about which filesystem
> hit the error...

If we are going to touch every one of these macros, then can we
rename them to something a little shorter like XFS_CORRUPT_GOTO()
and XFS_CORRUPT_RETURN() at the same time? That will make the code a
little less eye-bleedy where there are lots of these statements,
and make formatting of complex checks a bit easier, too...


Dave Chinner

<Prev in Thread] Current Thread [Next in Thread>