xfs
[Top] [All Lists]

Re: [PATCH 0/3] xfs: buffer types need to be set

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH 0/3] xfs: buffer types need to be set
From: Jan Kara <jack@xxxxxxx>
Date: Wed, 21 Jan 2015 17:07:57 +0100
Cc: xfs@xxxxxxxxxxx, jack@xxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <1421800780-26008-1-git-send-email-david@xxxxxxxxxxxxx>
References: <1421800780-26008-1-git-send-email-david@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
   Hi Dave,

On Wed 21-01-15 11:39:37, Dave Chinner wrote:
> These three patches detect and fix the issues you reported with log
> recovery finding buffers with a format type of zero. The type of
> zero (XFS_BLFT_UNKNOWN_BUF) is only valid for buffers that have
> been cancelled (i.e. invalidated or marked stale as they have been
> freed), so the series adds asserts to ensure these conditions are
> met during transaction commit. Hence we shouldn't ever get new code
> that fails to set the buffer type getting through testing.
> 
> The last two patches fix the cases that running xfstests uncovered
> where we don't set the buffer type appropriately. There may be more,
> but doing this much made my head hurt and xfstests is clean, so it's
> as much as I'm going to do right now. Can you test it and see if it
> runs clean (with CONFIG_XFS_WARN=y or CONFIG_XFS_DEBUG=y) on your
> test setup?
  Thanks for a quick response with patches. My test round has finished and
the new assertion didn't trigger so things look fine. I've also provided a
test kernel to the guy seeing these issues in the wild but there it took
days / weeks to trigger so I wouldn't wait for it...

                                                                Honza
-- 
Jan Kara <jack@xxxxxxx>
SUSE Labs, CR

<Prev in Thread] Current Thread [Next in Thread>