[Top] [All Lists]

Re: [PATCH 04/11] quota: Split ->set_xstate callback into two

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: [PATCH 04/11] quota: Split ->set_xstate callback into two
From: Jan Kara <jack@xxxxxxx>
Date: Tue, 18 Nov 2014 17:05:09 +0100
Cc: Jan Kara <jack@xxxxxxx>, linux-fsdevel@xxxxxxxxxxxxxxx, linux-ext4@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20141113173416.GA31481@xxxxxxxxxxxxx>
References: <1415739865-2438-1-git-send-email-jack@xxxxxxx> <1415739865-2438-5-git-send-email-jack@xxxxxxx> <20141113173416.GA31481@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Thu 13-11-14 09:34:16, Christoph Hellwig wrote:
> On Tue, Nov 11, 2014 at 10:04:18PM +0100, Jan Kara wrote:
> > Split ->set_xstate callback into two callbacks - one for turning quotas
> > on (->sysquota_on) and one for turning quotas off (->sysquota_off). That
> > way we don't have to pass quotactl command into the callback which seems
> > cleaner.
> Yes, I much prefer these to be split.  But the names seem a little odd,
> why not enable_quota/disable_quota?
  I wanted to clearly separate this from quota_on() / quota_off() callbacks
which are for userspace visible quota files. However enable_quota /
disable_quota sound fine as well.
> > +static unsigned int generic_to_xfs_flags(unsigned int uflags)
> xfs_quota_flags() ?

Jan Kara <jack@xxxxxxx>

<Prev in Thread] Current Thread [Next in Thread>