[Top] [All Lists]

Re: [PATCH 04/11] quota: Split ->set_xstate callback into two

To: Jan Kara <jack@xxxxxxx>
Subject: Re: [PATCH 04/11] quota: Split ->set_xstate callback into two
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Thu, 13 Nov 2014 09:34:16 -0800
Cc: linux-fsdevel@xxxxxxxxxxxxxxx, linux-ext4@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <1415739865-2438-5-git-send-email-jack@xxxxxxx>
References: <1415739865-2438-1-git-send-email-jack@xxxxxxx> <1415739865-2438-5-git-send-email-jack@xxxxxxx>
User-agent: Mutt/1.5.23 (2014-03-12)
On Tue, Nov 11, 2014 at 10:04:18PM +0100, Jan Kara wrote:
> Split ->set_xstate callback into two callbacks - one for turning quotas
> on (->sysquota_on) and one for turning quotas off (->sysquota_off). That
> way we don't have to pass quotactl command into the callback which seems
> cleaner.

Yes, I much prefer these to be split.  But the names seem a little odd,
why not enable_quota/disable_quota?

> +static unsigned int generic_to_xfs_flags(unsigned int uflags)

xfs_quota_flags() ?

<Prev in Thread] Current Thread [Next in Thread>