[Top] [All Lists]

Re: [PATCH 2/2] Add support to RENAME_EXCHANGE flag

To: xfs@xxxxxxxxxxx
Subject: Re: [PATCH 2/2] Add support to RENAME_EXCHANGE flag
From: Carlos Maiolino <cmaiolino@xxxxxxxxxx>
Date: Mon, 10 Nov 2014 16:56:47 -0200
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <5461002E.8090506@xxxxxxxxxxx>
Mail-followup-to: xfs@xxxxxxxxxxx
References: <1415641272-29383-1-git-send-email-cmaiolino@xxxxxxxxxx> <1415641272-29383-3-git-send-email-cmaiolino@xxxxxxxxxx> <5461002E.8090506@xxxxxxxxxxx>
User-agent: Mutt/1.5.23 (2014-03-12)
On Mon, Nov 10, 2014 at 12:13:02PM -0600, Eric Sandeen wrote:
> On 11/10/14 11:41 AM, Carlos Maiolino wrote:
> > Adds a new function named xfs_cross_rename(), responsible to handle requests
> > from sys_renameat2() using RENAME_EXCHANGE flag.
> > 
> > Changelog:
> > 
> >     V2: refactor xfs_cross_rename() to not duplicate code from xfs_rename()
> Which tree is this against?

It's based on an 'old' version of linux.git, which I was using when I started to
work on this patch, I'll rebase it on top of the current tree.

> Ok, just some style drive-by comments, first -
> EEK ;)  13 args and ~100 chars wide ;)
> You could at least move some of those back to local vars in the
> cross_rename function so you don't have to pass them on the stack.
> It's also customary to pass the transaction pointer as the first arg,
> i.e.:
> There are a few other places where you go well beyond 80 chars, would rather
> not do that if at all possible.
Yes, after reading it on the list, although it works, it looks a mess :( sorry
about it.

I'll wait for some other comments and re-work on it, so, tomorrow I can send a
new version of it.

Thanks for the comments Eric


<Prev in Thread] Current Thread [Next in Thread>