xfs
[Top] [All Lists]

Re: Can't build RPM of xfstests

To: Eric Sandeen <sandeen@xxxxxxxxxxx>,Dave Chinner <david@xxxxxxxxxxxxx>,"Kaul, Yaniv" <Yaniv.Kaul@xxxxxxx>
Subject: Re: Can't build RPM of xfstests
From: Greg Freemyer <greg.freemyer@xxxxxxxxx>
Date: Mon, 20 Oct 2014 07:55:08 -0400
Cc: esandeen@xxxxxxxxxx,fstests@xxxxxxxxxxxxxxx,"xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=user-agent:in-reply-to:references:mime-version :content-transfer-encoding:content-type:subject:from:date:to:cc :message-id; bh=P2YcfDMXeGsr0T0VCsJxD3vc6vmXspNIgJzGWQDxfbs=; b=jFioecmA0F2f585cQj1lAfNuLMTUI1NT/SnD/xPHpMKHHodKfHw2m0aoIE6J8JEHOL 8jW7/Hd+n0tVKkq8vbOlPOaD54Dnm9JFZpnNFQyryjYsrb80bxxnT8qnANcEy+ykzW6e PqEFSUOCRbfZ+Kq0+Jt/gJtmJAqi5jvaNBoL23X+InfHT6uBlqIjGuHEBSzuvwyEbDYJ jLeXTIBRF+MYUrjvU6s/cCwoddZiS2DDJQro8PCCDlsXjEBqqfMgF+D+TNu79koSWEop PLO82Gzr8J3tt0epXhY203c6QSITlE1wZbw/mvYwAoCkext5wkk6BNsKmYqADpFg8iDu /tNw==
In-reply-to: <54448313.7040602@xxxxxxxxxxx>
References: <648473255763364B961A02AC3BE1060D03C7940C13@xxxxxxxxxxxxxxxxxx> <20141020014750.GL7169@dastard> <54448313.7040602@xxxxxxxxxxx>
User-agent: K-9 Mail for Android

On October 19, 2014 11:35:47 PM EDT, Eric Sandeen <sandeen@xxxxxxxxxxx> wrote:
>On 10/19/14 8:47 PM, Dave Chinner wrote:
>> [ cc fstests@xxxxxxxxxxxxxxx ]
>
>...
>
>>> === rpm ===
>>> /bin/sed -e's|@pkg_name@|xfstests|g' \
>>>         -e's|@pkg_version@|1.1.1|g' \
>>>         -e's|@pkg_release@|1|g' \
>>>         -e's|@pkg_distribution@|Linux|g' \
>>>         -e's|@build_root@|/tmp/34943|g' \
>>>         -e'/^BuildRoot: *$/d' \
>>>         -e's|@make@|/usr/bin/gmake|g' < xfstests.spec.in >
>xfstests.spec
>>> /usr/bin/rpmbuild -ba --rcfile ./rpm-4.rc xfstests.spec
>>> error: File /root/rpmbuild/SOURCES/xfstests-1.1.1.src.tar.gz: No
>such file or directory
>>> gmake[1]: *** [dist] Error 1
>> 
>> I've never tried to build xfstests packages, so I'd make the
>> assumption that the package build infrastructure is broken and needs
>> fixing.  That's looking for the tarball in the wrong place. My naive
>> reading of that is rpmbuild is expecting to run as root, not as a
>> jenkins user....
>> 
>> Eric, you're the local RPM expert - any ideas?
>> 
>> FWIW, I'll take whatever patches you guys come up with that make it
>> build rpms properly. ;)
>
>xfstests rpms have just never been a priority for me.  I run it just
>fine out
>of a checked-out git repo, and it doesn't require installation; on the
>other
>hand, making it palatable for a proper FHS-compliant distro package
>would
>require a fair bit of restructuring beyond just the packaging scripts.
>
>And... I honestly have no idea how the Makepkgs stuff is supposed to
>work.
>
>I've never been a fan of upstream containing packaging bits anyway;
>different
>distros have different requirements, and the Makepkgs script has always
>seemed
>weird.  RPM/specfiles are supposed to drive the build - the build isn't
>supposed
>to drive rpm.  I think it'd be best to make a distro-specific specfile
>which knows how
>to handle an xfstests tarball.  Trying to reverse engineer Makepkgs
>doesn't sound
>fun to me; rpmbuild knows how to do this stuff.  Dropping a generic RPM
>specfile
>into the top level dir would probably be enough to get it off the
>ground even if
>it doesn't conform to any particular distro's packaging rules.
>
>I think it's up to those who want rpms to dig into this, for now. 
>Dumping all
>files into /opt/xfstests is probably simplest, since FHS-compliance is
>probably a
>long ways off.
>
>-Eric

Opensuse is building rpms of 1.1.1 so the build infrastructure isn't too badly 
broken.  I don't know if they are following FHS, but I doubt they use /opt.

The opensuse package/specfile can be found at: 
https://build.opensuse.org/package/show/filesystems/xfstests

The rpms including the source rpm can be downloaded from:
http://software.opensuse.org/download.html?project=filesystems&package=xfstests

Note the specfile applies a patch to change the install aspect of the tarball 
immediately after untar'ing it.  

I don't maintain that so I don't know why the patch is needed.

Greg

-- 
Sent from my Android phone with K-9 Mail. Please excuse my brevity.

<Prev in Thread] Current Thread [Next in Thread>