xfs
[Top] [All Lists]

Re: Mount: Structure needs cleaning

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: Mount: Structure needs cleaning
From: Tom Mason <tom_mason@xxxxxx>
Date: Mon, 13 Oct 2014 11:05:49 +0100
Cc: Brian Foster <bfoster@xxxxxxxxxx>, "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20141012231001.GC5267@dastard>
References: <1413103408756-35026.post@xxxxxxxxxxxxx> <20141012142008.GB35667@xxxxxxxxxxxxxxx> <DUB113-W9BCC0D296AF7CD5D9D02FB6AF0@xxxxxxx> <DUB113-W8015EC9E74D26138852F2FB6AF0@xxxxxxx> <20141012231001.GC5267@dastard>



> On 13 Oct 2014, at 00:10, Dave Chinner <david@xxxxxxxxxxxxx> wrote:
> 
> [ please don't top post. ]
> 
> On Sun, Oct 12, 2014 at 10:48:36PM +0000, tom mason wrote:
>>> Date: Sun, 12 Oct 2014 10:20:08 -0400
>>> From: bfoster@xxxxxxxxxx
>>> To: tom_in_canada@xxxxxxxxxxx
>>> CC: xfs@xxxxxxxxxxx
>>> Subject: Re: Mount: Structure needs cleaning
>>> 
>>>> On Sun, Oct 12, 2014 at 01:43:28AM -0700, tommason wrote:
>>>> Hi,
>>>> 
>>>> First up - my knowledge of linux is pretty sparse - I've used it a few 
>>>> times
>>>> before, so please be gentle!
>>>> 
>>>> I've had a neil poulton network space for some time now - it freaked out a
>>>> while ago and I managed to rig it up to a Ubuntu liveCD via a SATA dock and
>>>> rescue the files.
>>>> 
>>>> This has now happened again - the drive would not get out of a cycle and 
>>>> was
>>>> not spinning properly. Bring out the dock and liveCD (this time Knoppix).
>>>> All good. This time however as I eagerly copied files to another drive (a
>>>> USB powered lacie rugged thing) and left it overnight i woke up to an 
>>>> error.
>>>> I was copying around 500GB in a few diffferent chunks. The first error it
>>>> reported was I think error 15? mount structure needs cleaning...
>> 
>> 
>>> Logs? Kernel version? etc.
>> 
>> Hey Brian,
>> Apologies! I'm pretty new to all this so you'll have to walk me through it 
>> if possible - how do I check the logs?
>> 
>> - Linux ubuntu 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 
>> x86_64 x86_64 x86_64 GNU/Linux
>> - xfs_repair version 3.1.9
>> 
>> ok - so I worked out & tried the xfs_repair command:
>> 
>> root@ubuntu:~# xfs_repair -n /dev/sdc2
>> Phase 1 - find and verify superblock...
>> superblock read failed, offset 62448377856, size 131072, ag 2, rval -1
>> 
>> fatal error -- Input/output error
> 
> Which means the filesystem tried to read the offset at 62GB and the
> underlying device failed it with EIO. That's not an XFS failure.
> What error is there in dmesg when you run that xfs_repair command?

What's EIO?
'Error in dmesg' How would I report this info to you? 





> 
>>> http://xfs.org/index.php/XFS_FAQ#Q:_What_information_should_I_include_when_reporting_a_problem.3F
> 
> This asks you to post the contents of /proc/partitions, which is
> what the kernel thinks are the partition sizes.

How do I do this?


> 
>> Yes it's a NAS drive and so I assume had some kind of proprietary
>> OS on the other partitions (this is where i might have messed up
>> by deleting?!) I'm pretty sure that the drive in bold below (sdc2)
>> is the one I'm after which is xfs...
> 
> Ummm, exactly what are you trying to do with this drive/filesystem?
> What device did the drive come from in the first place?

It's a lacie 'Neil poulton' network space1 1tb NAS drive (see first paragraph 
of post) - it recently stopped working and was stuck in a 'spin cycle' - it 
contains my music and video backups. I'm trying to recover the files...

Cheers,

Tom



> 
> Cheers,
> 
> Dave.
> -- 
> Dave Chinner
> david@xxxxxxxxxxxxx
> 

<Prev in Thread] Current Thread [Next in Thread>