xfs
[Top] [All Lists]

Re: Test xfs/287 failure

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: Test xfs/287 failure
From: Jan Kara <jack@xxxxxxx>
Date: Thu, 2 Oct 2014 09:45:34 +0200
Cc: Jan Kara <jack@xxxxxxx>, xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20141001224155.GW4758@dastard>
References: <20141001152314.GH17405@xxxxxxxxxxxxx> <20141001224155.GW4758@dastard>
User-agent: Mutt/1.5.21 (2010-09-15)
On Thu 02-10-14 08:41:55, Dave Chinner wrote:
> On Wed, Oct 01, 2014 at 05:23:14PM +0200, Jan Kara wrote:
> >   Hello,
> > 
> >   so after installing latest xfsdump (just pulled git repo at oss.sgi.com),
> > I'm getting failure in test xfs/287. The failure is:
> > xfs/287 2s ... 2s
> > _check_xfs_filesystem: filesystem on /dev/vdb2 is inconsistent (r) (see
> > /var/lib/xfstests/results//xfs/287.full)
> > 
> > And the 287.full has:
> > ...
> > Phase 3 - for each AG...
> >         - scan (but don't clear) agi unlinked lists...
> >         - process known inodes and perform inode discovery...
> >         - agno = 0
> > directory flags set on non-directory inode 133
> > directory flags set on non-directory inode 134
> > directory flags set on non-directory inode 133
> > would fix bad flags.
> > directory flags set on non-directory inode 134
> > would fix bad flags.
> > ...
> > 
> > Complete file is attached. I'm using also the latest xfsprogs from git and
> > kernel 3.17.0-rc5 (plus couple of my patches but these should have no
> > influence).
> 
> It's a bug, but a minor inconvenience at worst. I sent patches to
> fix this a couple of days ago:
> 
> http://oss.sgi.com/archives/xfs/2014-09/msg00510.html
  Ah, OK. Thanks for info. I was just going through xfstests failures in my
test VM and fixing xfstests / my setup and I wasn't able to figure out this
one...

                                                                Honza
-- 
Jan Kara <jack@xxxxxxx>
SUSE Labs, CR

<Prev in Thread] Current Thread [Next in Thread>