xfs
[Top] [All Lists]

mkfs.xfs fails with raid5 and smaller chunk sizes

To: <xfs@xxxxxxxxxxx>
Subject: mkfs.xfs fails with raid5 and smaller chunk sizes
From: Brian Hemme <bmh@xxxxxxxxxx>
Date: Tue, 16 Sep 2014 15:03:08 -0700
Delivered-to: xfs@xxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:7.0.1) Gecko/20110929 Thunderbird/7.0.1
Hello all,

I am having some odd problems with mkfs.xfs when used on a raid 5 array. The array is built from 6 960GB SSDs all connected to SATA ports on the MB and created with mdadm. If I use a chunk size any smaller then 512K mkfs.xfs just hangs forever. It continues to use CPU and so does the raid array but never completes. If the system is just left running for an extended length of time the whole OS eventually locks up. I have tried this on three different systems with the same results. I have searched all over for someone with similar issues without success. I am hoping I am just doing something clearly wrong and you all can set me straight quickly.

Some specifics:
    Arch linux with 3.14.1 kernel
    mkfs.xfs version 3.1.11
    mdadm - v3.3 - 3rd September 2013

Commands:
> mdadm --create /dev/md0 --chunk=64K --level=5 --raid-devices=6 /dev/sd[a-f]
> mkfs.xfs /dev/md0
  ** This command fails and locks up

I have tried specifying the arguments to mkfs.xfs with the same results. Building a 4 drive array seems to require a chunk size of 1M or greater to work. Same results if I make a partition on the array and make the fs there.

Any help would be appreciated
Thanks
Brian

<Prev in Thread] Current Thread [Next in Thread>