xfs
[Top] [All Lists]

Re: Problem building xfsprogs

To: scameron@xxxxxxxxxxxxxxxxxx
Subject: Re: Problem building xfsprogs
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Thu, 24 Jul 2014 08:19:23 +1000
Cc: fstests@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20140723140118.GI14599@xxxxxxxxxxxxxxxxxx>
References: <20140722160641.GU17967@xxxxxxxxxxxxxxxxxx> <20140722205605.GJ20518@dastard> <20140722210951.GE14599@xxxxxxxxxxxxxxxxxx> <20140722214727.GP4453@dastard> <20140723140118.GI14599@xxxxxxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Wed, Jul 23, 2014 at 09:01:18AM -0500, scameron@xxxxxxxxxxxxxxxxxx wrote:
> On Wed, Jul 23, 2014 at 07:47:27AM +1000, Dave Chinner wrote:
> > Can you please attach the built include/builddefs and
> > include/platform_defs.h files that autoconf built?
.....
> 
> PKG_NAME      = xfsprogs
> PKG_USER      = relliott
> PKG_GROUP     = relliott
> PKG_RELEASE   = 1
> PKG_VERSION   = 3.2.1
> PKG_PLATFORM  = srcv

I'd say that's your problem right there - your system is not
identifying itself as a linux machine according to autoconf. i.e.
that should say "linux", not "srcv".  That'll make the rest of the
makefiles behave strangely, as nothing that is conditional for the
linux build to work will be added or run.

I guess we now need to look into why autoconf is giving
this result. Can you look in the autoconf output and config.* files
to see why it's coming up with this platform?

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>