xfs
[Top] [All Lists]

Re: symlink loop for /lib64/libhandle.so

To: Jan ÅulÃk <jan@xxxxxxxx>, Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: symlink loop for /lib64/libhandle.so
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Thu, 10 Jul 2014 11:40:07 -0500
Cc: Brian Foster <bfoster@xxxxxxxxxx>, XFS mail list <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <1405009872.31068.22.camel@jtulak>
References: <1404898212.7231.12.camel@jtulak> <20140709132836.GA65226@xxxxxxxxxxxxxxx> <20140710134851.GA26652@xxxxxxxxxxxxx> <1405009872.31068.22.camel@jtulak>
On 7/10/14, 11:31 AM, Jan ÅulÃk wrote:
> 
>> On 10 Jul 2014, at 15:48, Christoph Hellwig <hch@xxxxxxxxxxxxx> wrote:
>>
>> On Wed, Jul 09, 2014 at 09:28:36AM -0400, Brian Foster wrote:
>>>> If it not an intended behavior, I can try to find the source of the bug
>>>> and make a patch (I'm new here :-).
>>>
>>> I can reproduce this on fedora rawhide via 'make install-qa.' This is
>>> not intended behavior. I couldn't tell you what the problem is, but
>>> patches are certainly welcome. :)
>>
>> This sounds like an fallout from the /lib -> /usr/lib symlink mess in
>> Fedora.  Might be worth taking a look at the specfile how Eric worked
>> around that for the RPM..

I'm pretty sure I used a terrible hack in the specfile... ;)
 
> Yes. I'm trying to find out what exactly is causing the difference. I
> have tried to use the same tarball which is used in Eric's RPM and it
> did the same thing as the git version, so it is not something that
> would change since his last build.

The tarball I use in the RPM is exactly what is provided on oss.sgi.com,
there's nothing different in there for Fedora.

> So far It seems that if I add DIST_ROOT, PKG_ROOT_SBIN_DIR and
> PKG_ROOT_LIB_DIR arguments to the "make install-qa" commandm it works OK and
> the libhandle.so placed in PKG_ROOT_LIB_DIR points correctly to
> libandle.so.1.
> 
> Does this makes some sense to you?

Here's what the current RPM build does; I don't claim that it's elegant or
beautiful:

%install
rm -rf $RPM_BUILD_ROOT
make V=1 DIST_ROOT=$RPM_BUILD_ROOT install install-dev install-qa \
        PKG_ROOT_SBIN_DIR=%{_sbindir} PKG_ROOT_LIB_DIR=%{_libdir}

so that sounds like what you're doing, too.

FWIW, that above change also removed this old cruft, and I don't remember what
it was for:

-# fix up symlink to be correct
-rm -f $RPM_BUILD_ROOT/%{_libdir}/libhandle.so
-ln -s ../../%{_lib}/libhandle.so.1 $RPM_BUILD_ROOT/%{_libdir}/libhandle.so

so I'm probably guilty of hacking stuff up too much for Fedora, vs fixing
it upstream... :(

-Eric

<Prev in Thread] Current Thread [Next in Thread>