xfs
[Top] [All Lists]

Re: symlink loop for /lib64/libhandle.so

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: symlink loop for /lib64/libhandle.so
From: Jan ÅulÃk <jan@xxxxxxxx>
Date: Thu, 10 Jul 2014 18:31:12 +0200
Cc: Brian Foster <bfoster@xxxxxxxxxx>, XFS mail list <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20140710134851.GA26652@xxxxxxxxxxxxx>
References: <1404898212.7231.12.camel@jtulak> <20140709132836.GA65226@xxxxxxxxxxxxxxx> <20140710134851.GA26652@xxxxxxxxxxxxx>
> On 10 Jul 2014, at 15:48, Christoph Hellwig <hch@xxxxxxxxxxxxx> wrote:
> 
> On Wed, Jul 09, 2014 at 09:28:36AM -0400, Brian Foster wrote:
>>> If it not an intended behavior, I can try to find the source of the bug
>>> and make a patch (I'm new here :-).
>> 
>> I can reproduce this on fedora rawhide via 'make install-qa.' This is
>> not intended behavior. I couldn't tell you what the problem is, but
>> patches are certainly welcome. :)
> 
> This sounds like an fallout from the /lib -> /usr/lib symlink mess in
> Fedora.  Might be worth taking a look at the specfile how Eric worked
> around that for the RPM..

Yes. I'm trying to find out what exactly is causing the difference. I
have tried to use the same tarball which is used in Eric's RPM and it
did the same thing as the git version, so it is not something that
would change since his last build.

So far It seems that if I add DIST_ROOT, PKG_ROOT_SBIN_DIR and
PKG_ROOT_LIB_DIR arguments to the "make install-qa" commandm it works OK and
the libhandle.so placed in PKG_ROOT_LIB_DIR points correctly to
libandle.so.1.

Does this makes some sense to you?

Jan Tulak

<Prev in Thread] Current Thread [Next in Thread>