xfs
[Top] [All Lists]

Re: xfs_repair 3.2.0 cannot (?) fix fs

To: xfs@xxxxxxxxxxx
Subject: Re: xfs_repair 3.2.0 cannot (?) fix fs
From: Arkadiusz MiÅkiewicz <arekm@xxxxxxxx>
Date: Sun, 29 Jun 2014 00:01:38 +0200
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=maven.pl; s=maven; h=from:to:subject:date:user-agent:references:in-reply-to:mime-version :content-type:content-transfer-encoding:message-id; bh=Asbzw8TiWG3ZfTLHpi/zckJgbRD6vjcoWYPleUbF9E4=; b=dIelx/Qvctkz7ZcnrVOmF7ENJRsguc9vP+6u+EwsyhT7/Nj2OiMEieb07arcAWgixe o7Wmu2tbAppO5idCqFLSufLjfC8mDZFJqlwZJDTdZd/0o6l5zJgAwkGuDtLJUwNYIZAm BC7wfWNbwi8wgvzDmcjcLK2T7MMZTOnitUyzM=
In-reply-to: <201406282352.56431.arekm@xxxxxxxx>
References: <201406280141.54350.arekm@xxxxxxxx> <201406282352.56431.arekm@xxxxxxxx>
User-agent: KMail/1.13.7 (Linux/3.16.0-rc2-00211-gd7933ab; KDE/4.13.2; x86_64; ; )
On Saturday 28 of June 2014, Arkadiusz MiÅkiewicz wrote:
> On Saturday 28 of June 2014, Arkadiusz MiÅkiewicz wrote:
> > Hello.
> > 
> > I have a fs (metadump of it
> > http://ixion.pld-linux.org/~arekm/p2/x1/web2-home.metadump.gz)
> > that xfs_repair 3.2.0 is unable to fix properly.
> > 
> > Running xfs_repair few times shows the same errors repeating:
> > http://ixion.pld-linux.org/~arekm/p2/x1/repair2.txt
> > http://ixion.pld-linux.org/~arekm/p2/x1/repair3.txt
> > http://ixion.pld-linux.org/~arekm/p2/x1/repair4.txt
> > http://ixion.pld-linux.org/~arekm/p2/x1/repair5.txt
> > 
> > (repair1.txt also exists - it was initial, very big/long repair)
> > 
> > Note that fs mounts fine (and was mounting fine before and after repair)
> > but xfs_repair indicates that not everything got fixed.
> > 
> > 
> > Unfortunately there looks to be a problem with metadump image. xfs_repair
> > is able to finish fixing on a restored image but is not able (see
> > repairX.txt) above on real devices. Huh?
> 
> Made xfs metadump without file obfuscation and I'm able to reproduce the
> problem reliably on the image (if some xfs developer wants metadump image
> then please mail me - I don't want to put it for everyone due to obvious
> reasons).

Forgot to mention about new problem. After running xfs_repair (reproducible on 
real fs and on metadump) and trying to mount fs:

[3571367.717167] XFS (loop0): Mounting Filesystem
[3571367.883958] XFS (loop0): Ending clean mount
[3571367.900733] XFS (loop0): Failed to initialize disk quotas.

Files are accessible etc. Just no quota. Unfortunately no information why 
initialization failed.

So xfs_repair wasn't able to fix that, too.

-- 
Arkadiusz MiÅkiewicz, arekm / maven.pl

<Prev in Thread] Current Thread [Next in Thread>