xfs
[Top] [All Lists]

Re: XFS Repair hangs at inode repair in phase3

To: Dragon <Sunghost@xxxxxx>, xfs@xxxxxxxxxxx
Subject: Re: XFS Repair hangs at inode repair in phase3
From: Stan Hoeppner <stan@xxxxxxxxxxxxxxxxx>
Date: Thu, 26 Jun 2014 18:32:25 -0500
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <trinity-20fa04a2-b771-42eb-afb3-a915026306bd-1403810247665@3capp-gmx-bs14>
References: <trinity-20fa04a2-b771-42eb-afb3-a915026306bd-1403810247665@3capp-gmx-bs14>
Reply-to: stan@xxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
On 6/26/2014 2:17 PM, Dragon wrote:
> Hello,
> i upgraded to debian jessie with xfsprogs 3.2. if i run xfs_repair /dev/md2 
> the system hangs too. If i use -P it ends up with:
> corrupt block 0 in directory inode 2147702899: junking block
> Segmentation fault
> 
> if i use -n -P it ends up with:
> 
> No modify flag set, skipping phase 5
> Inode allocation btrees are too corrupted, skipping phases 6 and 7
> No modify flag set, skipping filesystem flush and exiting.

Did you lose the md/RAID6 array and reassemble it prior to seeing the
problems with the XFS filesystem?  You may have reassembled it in the
wrong order, in which case the sector offsets will be wrong, and XFS
will not see data where it should be.  This is reported as corruption.
You never posted your dmesg output so you may or may not be experiencing
hardware problems.  That needs to be eliminated as a possible cause.
Please post relevant lines from dmesg.

> Files are still not accessible - i think i lost some TB ;( - not a good 
> experience for first use of xfs...

An XFS filesystem doesn't simply become corrupt like this during normal
operation.  Something happened that corrupted the on disk structures.
XFS is the messenger here, not the cause.

Cheers,

Stan

<Prev in Thread] Current Thread [Next in Thread>