xfs
[Top] [All Lists]

Re: XFS Repair hangs at inode repair in phase3

To: xfs@xxxxxxxxxxx
Subject: Re: XFS Repair hangs at inode repair in phase3
From: Dragon <Sunghost@xxxxxx>
Date: Thu, 26 Jun 2014 21:17:27 +0200
Delivered-to: xfs@xxxxxxxxxxx
Importance: normal
Sensitivity: Normal
Hello,
i upgraded to debian jessie with xfsprogs 3.2. if i run xfs_repair /dev/md2 the system hangs too. If i use -P it ends up with:
corrupt block 0 in directory inode 2147702899: junking block
Segmentation fault

if i use -n -P it ends up with:

No modify flag set, skipping phase 5
Inode allocation btrees are too corrupted, skipping phases 6 and 7
No modify flag set, skipping filesystem flush and exiting.

Files are still not accessible - i think i lost some TB ;( - not a good experience for first use of xfs...
On 6/24/2014 5:15 PM, Dragon wrote:
Hi, yes read this, but i am new and dont know what this command will do and i dont want to lost my data. I read in the net, that some people couldnt start or boot from that disk, after running xfs_repair. I looked for a upgrade to latest xfsprogs version, but it seems difficult for amd64 systems. Do you have a changelog to latest version, could my installed version be ok, or better not to use? Thx Stan and Eric
# xfs_repair -n -P /dev/device Post the output in your next reply, assuming it doesn't hang again. Cheers, Stan
<Prev in Thread] Current Thread [Next in Thread>