xfs
[Top] [All Lists]

Re: Metadata CRC error upon unclean unmount

To: Fanael Linithien <fanael4@xxxxxxxxx>
Subject: Re: Metadata CRC error upon unclean unmount
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Tue, 24 Jun 2014 14:45:37 -0500
Cc: xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <CA+o=1OXG9wY7pX3emPtRjdAQKC4MFKvJWiJsmD7yGmuJeXjPQQ@xxxxxxxxxxxxxx>
References: <CA+o=1OW0OXhzU+b9ACMZzg0dq=B7BSj+yPXD2Vrr9F6mWK8ruQ@xxxxxxxxxxxxxx> <53A9A295.8030302@xxxxxxxxxxx> <CA+o=1OXJZk2XjZhtEORQesDjb3VGzM1Ddk6DGXwuLhHJUEbjPQ@xxxxxxxxxxxxxx> <53A9C7EF.7010707@xxxxxxxxxxx> <CA+o=1OXG9wY7pX3emPtRjdAQKC4MFKvJWiJsmD7yGmuJeXjPQQ@xxxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
On 6/24/14, 2:00 PM, Fanael Linithien wrote:
> 2014-06-24 20:48 GMT+02:00 Eric Sandeen <sandeen@xxxxxxxxxxx>:
>> FWIW, I've been unable to reproduce this in about 4 attempts, using
>> virtualbox, and doing a guest reset.
> 
> Same here. The most breakage I can get is a log record CRC mismatch
> (still a bug, I think). I will report if I run across a metadata CRC
> error ever again.

The trouble with VMs is that we depend on the VM doing the right thing,
as well.  I can't blame VirtualBox here, but it definitely adds a layer
of complexity that we can't control.

I've still not been able to make anything go wrong in my testing.

-Eric

<Prev in Thread] Current Thread [Next in Thread>