xfs
[Top] [All Lists]

Re: [PATCH 0/6][RFC] Introduce FALLOC_FL_ZERO_RANGE flag for fallocate

To: LukÃÅ Czerner <lczerner@xxxxxxxxxx>
Subject: Re: [PATCH 0/6][RFC] Introduce FALLOC_FL_ZERO_RANGE flag for fallocate
From: Theodore Ts'o <tytso@xxxxxxx>
Date: Tue, 18 Feb 2014 09:23:05 -0500
Cc: Dave Chinner <david@xxxxxxxxxxxxx>, linux-ext4@xxxxxxxxxxxxxxx, linux-fsdevel@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=simple/simple; d=thunk.org; s=mail; t=1392733385; bh=1nl6apyicmVE51qphyWRTMemOpApo/cqjXB/fJiIWgY=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=mGwHnboIM8LooSEc2mCQWES3cveIfVVbrNrBZ1zUe+IeSPo4hOKV5eAaZmFhswVAy 486881I6//UXfd7aDzLhDSFUo2MBlqkoXSg0M/OkOM3Y8wCct5dJzp7MWJNDfJOa/r btHsUw48n1B1D1JRVNOkZIIKoG7Gk0nUYwaApGII=
In-reply-to: <alpine.LFD.2.00.1402181302230.2216@xxxxxxxxxxxxxxxxxxxxx>
References: <1392649703-10772-1-git-send-email-lczerner@xxxxxxxxxx> <20140218010138.GE13997@dastard> <20140218083324.GB28666@dastard> <alpine.LFD.2.00.1402181006250.2216@xxxxxxxxxxxxxxxxxxxxx> <20140218094142.GC28666@dastard> <alpine.LFD.2.00.1402181302230.2216@xxxxxxxxxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Tue, Feb 18, 2014 at 01:04:24PM +0100, LukÃÅ Czerner wrote:
>
> > Ok, so it's a "fallocate" test group, then?
> 
> More like "fsx_fsstress" group, which might sound as a terrible name
> for the group but it explains it quite well. So if you do not have
> anything against that I'll call the new group "fsx_fsstress"

How about "block_map" group?  I like Dave's suggestion about naming
the group after what it is trying to test, as opposed to how it does
that testing.  This is also consistent with how the other tests groups
are named in xfstests.

However, extents are an implementation strategy, and you might just as
easily use this test to verify whether or not the punch hole
functionality for indirect block maps worked correctly.

What I think using fsx and fstress together have in common is that
it's a great way of stress testing whatever the file system uses for
creating and maintaining the translation map between (inode, logical
block) to physical block, so that's why perhaps "block_map" might be a
good test group name.

Regards,

                                                - Ted

<Prev in Thread] Current Thread [Next in Thread>