[Top] [All Lists]

Re: [RFC] unifying write variants for filesystems

To: Al Viro <viro@xxxxxxxxxxxxxxxxxx>
Subject: Re: [RFC] unifying write variants for filesystems
From: Zach Brown <zab@xxxxxxxxxx>
Date: Tue, 4 Feb 2014 10:33:56 -0800
Cc: Kent Overstreet <kmo@xxxxxxxxxxxxx>, Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx>, Christoph Hellwig <hch@xxxxxxxxxxxxx>, Jens Axboe <axboe@xxxxxxxxx>, Mark Fasheh <mfasheh@xxxxxxxx>, Joel Becker <jlbec@xxxxxxxxxxxx>, linux-fsdevel <linux-fsdevel@xxxxxxxxxxxxxxx>, xfs@xxxxxxxxxxx, Sage Weil <sage@xxxxxxxxxxx>, Steve French <sfrench@xxxxxxxxx>, Anton Altaparmakov <anton@xxxxxxxxxx>, Dave Kleikamp <dave.kleikamp@xxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20140204180040.GI10323@xxxxxxxxxxxxxxxxxx>
References: <20140119051335.GN10323@xxxxxxxxxxxxxxxxxx> <20140120135514.GA21567@xxxxxxxxxxxxx> <CA+55aFzEA-eM9v2PvsWx4v4ANaKXuRGYyGCkegJg++rhtHvnig@xxxxxxxxxxxxxx> <20140201224301.GS10323@xxxxxxxxxxxxxxxxxx> <52EFC271.3090205@xxxxxxxxxx> <20140204124409.GG10323@xxxxxxxxxxxxxxxxxx> <20140204125220.GB12440@kmo-pixel> <20140204151728.GH10323@xxxxxxxxxxxxxxxxxx> <20140204172723.GA11325@xxxxxxxxxxxxxxxxxxxx> <20140204180040.GI10323@xxxxxxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
> > > BTW, folks, any suggestions about the name of that "memory stream" thing?
> > > struct iov_iter really implies iterator for iovec and more generic name
> > > would probably be better...  struct mem_stream would probably do if nobody
> > > comes up with better variant, but it's long and somewhat clumsy...
> > 
> > I don't like 'stream'.  To me that sounds more strictly advancing than I
> > think this'd be capable of.  Maybe something dirt simple like 'mem_vec'?
> > With 'mvec_' call prefixes?
> Umm...  Frankly, I would rather discourage attempts to read the same data
> twice, if only on the naming level...

Ahh, OK, sure.  mem_iter?

- z

<Prev in Thread] Current Thread [Next in Thread>