xfs
[Top] [All Lists]

Not being able to recover a RAID 5 20 Tb partition, help needed

To: xfs@xxxxxxxxxxx
Subject: Not being able to recover a RAID 5 20 Tb partition, help needed
From: "Juan A. Sillero" <sillero@xxxxxxxxxxxxxxxxxx>
Date: Wed, 29 Jan 2014 14:39:55 +0100
Delivered-to: xfs@xxxxxxxxxxx
Organization: UPM
Reply-to: sillero@xxxxxxxxxxxxxxxxxx
Hello,

We are a pioneering group in turbulence at the Polytechnic University of
Madrid (torroja.dmt.upm.es), running simulations in supercomputing
centers all around the world and hosting massive data in our data center
that are publicly accessible.

Apparently we have lost one of our partitions of 20 Tb because of a
under-voltage error of a power source plus a disk failure and we are
trying to fix it, but it does not look good so far.

The system is setup as follow:
        XFS 6.1
        Raid 5 (12 x 2 disks of 2 Tb each)
        Double disk controller managed by devmapper.

What we know at this point is the next:

1) The topology of the disk is lost: the main-boot-record and the GPT
are corrupted. 
2) After running the testdisk utility we find 9 partitions instead of 1.
3) With gdisk we have tried to create a new main-boot-record and GPT,
but it has not worked. 
4) We know that the blocksize is 4096 bytes, and the current capacity of
the raid is under 20 Tb, so we suspect that even if the disk-manager
says that the RAID is ok, it has not reconstructed the RAID after the
disk failing.

We are stuck right now at this point, and help would be really
appreciated in order to bring up the partition. We will be pleased to
acknowledge the group in the upcoming publications.

Thanks again, Juan A. Sillero 




<Prev in Thread] Current Thread [Next in Thread>