[Top] [All Lists]

Re: [PATCH 4/4] xfs: rename mem_to_page to xfs_bufmem_to_page

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: [PATCH 4/4] xfs: rename mem_to_page to xfs_bufmem_to_page
From: Jeff Liu <jeff.liu@xxxxxxxxxx>
Date: Thu, 26 Dec 2013 18:44:24 +0800
Cc: "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20131226100825.GB11950@xxxxxxxxxxxxx>
References: <52B982AF.2060607@xxxxxxxxxx> <20131226100825.GB11950@xxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.1.0
On 12/26 2013 18:08 PM, Christoph Hellwig wrote:
> On Tue, Dec 24, 2013 at 08:48:47PM +0800, Jeff Liu wrote:
>> From: Jie Liu <jeff.liu@xxxxxxxxxx>
>> Rename mem_to_page() to xfs_bufmem_to_page() for XFS convention.
> There's nothing inherently buffere related in the function, it doesn't
> even take an argument related to buffers.
Well, I originally want to rename to xfs_buf_mem_to_page() by following
up other functions in this file with "xfs_buf_" prefix, something like
a typo...

Looks this routine can not be folded into xfs_buf_associate_memory()
without introducing another variable to hold the temporary type convert
value of pageaddr, so I'm fine if we remains the same.


<Prev in Thread] Current Thread [Next in Thread>