xfs
[Top] [All Lists]

Re: XFS_REPAIR on LVM partition

To: Rafael Weingartner <rafaelweingartner@xxxxxxxxx>
Subject: Re: XFS_REPAIR on LVM partition
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Mon, 16 Dec 2013 11:01:41 +1100
Cc: xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <CAG97raf61XGnTakrYjcfv9cjM6CTVdEEB3wQK+wOBvpowWO3Cw@xxxxxxxxxxxxxx>
References: <CAG97raf61XGnTakrYjcfv9cjM6CTVdEEB3wQK+wOBvpowWO3Cw@xxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Sun, Dec 15, 2013 at 08:47:30PM -0200, Rafael Weingartner wrote:
> Hi folks,
> I am having some troubles with a XFS over one LVM partition. After an
> unexpected reboot, I am getting the following message when I try to mount
> it:
> *mount: Structure needs cleaning*

And the error in dmesg is?

> I tried "sudo xfs_check /dev/mapper/volume". Sadly, I got the message:
> xfs_check: cannot init perag data (117)

xfs_check is deprecated, please use "xfs_repair -n" instead.

> *ERROR: The filesystem has valuable metadata changes in a log which needs
> to*
> *be replayed.  Mount the filesystem to replay the log, and unmount it
> before*
> *re-running xfs_check.  If you are unable to mount the filesystem, then use*
> *the xfs_repair -L option to destroy the log and attempt a repair.*
> *Note that destroying the log may cause corruption -- please attempt a
> mount*
> *of the filesystem before doing this*
> 
> So, I tried:
> xfs_repair -L

Ok, so you went immediately for the big hammer. There's the
possibility that might not be able to recover your filesystem from
whatever went wrong now that the log has been zeroed.

> The command is running for over 3 hours and still just dots on my screen, I
> have no idea of what is happening. Any ideas how I can get it to work
> again? Or at least some work around that would enable me to extract the
> data that it contains.

I'm guessing it can't find or validate the primary superblock, so
it's looking for a secondary superblock. Please post the output of
the running repair so we can see exactly what it is doing.

Also we need more information about your problem - why did the
machine reboot? what's your storage configuration? You hardware,
etc.

http://xfs.org/index.php/XFS_FAQ#Q:_What_information_should_I_include_when_reporting_a_problem.3F

> The server is a Ubuntu server 12.04.
> The XFS version is: xfs_info version 3.1.7
> If you need I can provide you with more info.

That's an old version of xfsprogs - you might want to start by
upgrading it to 3.11...

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>