xfs
[Top] [All Lists]

XFS_REPAIR on LVM partition

To: xfs@xxxxxxxxxxx
Subject: XFS_REPAIR on LVM partition
From: Rafael Weingartner <rafaelweingartner@xxxxxxxxx>
Date: Sun, 15 Dec 2013 20:47:30 -0200
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:date:message-id:subject:from:to:content-type; bh=Nkf4jE8rXBtZP1ptoCaM7R16qyB2Na7Nj77G9qNYf18=; b=x2PHex6SVeqEexPI5FXC7qa5a/89siG0irPSslGjTqVQ0zmjVTQeBfXRE3FdpzmT4s 3z2d77XD5HdcJW4VvhQGYW+IEQw6K9Q0q3F0SIZsd/83JA2U0OJdTxv08jm4d14fKPEB ik8MQFa7TismUlx9Jt7Mp4m2DjYE2BjwU8UzCIHqf5tDt4Q7HVMavEpKtZSzo/lsp9wa R85AfznL4iSu3rLv04MWkkDv2d4vH7jzwt554QfyM4RnNT0TtP9+GxOSQSb4dGJ6YUmh icbI+oeCO8zPZ9WKyEqXiDwdP4M2tt8GBWYh7z10O6grZaEvTUt6C+VeXF3QBtBVqWQL ZmRg==
Hi folks, 
I am having some troubles with a XFS over one LVM partition. After an unexpected reboot, I am getting the following message when I try to mount it:
mount: Structure needs cleaning


I tried "sudo xfs_check /dev/mapper/volume". Sadly, I got the message:
xfs_check: cannot init perag data (117)
ERROR: The filesystem has valuable metadata changes in a log which needs to
be replayed.  Mount the filesystem to replay the log, and unmount it before
re-running xfs_check.  If you are unable to mount the filesystem, then use
the xfs_repair -L option to destroy the log and attempt a repair.
Note that destroying the log may cause corruption -- please attempt a mount
of the filesystem before doing this

So, I tried:
xfs_repair -L 

The command is running for over 3 hours and still just dots on my screen, I have no idea of what is happening. Any ideas how I can get it to work again? Or at least some work around that would enable me to extract the data that it contains.

The server is a Ubuntu server 12.04.
The XFS version is: xfs_info version 3.1.7
If you need I can provide you with more info.

Thanks,

--
Rafael Weingärtner
<Prev in Thread] Current Thread [Next in Thread>