xfs
[Top] [All Lists]

Re: [PATCH 01/15] xfsprogs: use common code for multi-disk detection

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: [PATCH 01/15] xfsprogs: use common code for multi-disk detection
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Tue, 3 Dec 2013 09:49:19 +1100
Cc: xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20131202104016.GA21394@xxxxxxxxxxxxx>
References: <1385689430-10103-1-git-send-email-david@xxxxxxxxxxxxx> <1385689430-10103-2-git-send-email-david@xxxxxxxxxxxxx> <20131202104016.GA21394@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Mon, Dec 02, 2013 at 02:40:16AM -0800, Christoph Hellwig wrote:
> On Fri, Nov 29, 2013 at 12:43:36PM +1100, Dave Chinner wrote:
> > From: Dave Chinner <dchinner@xxxxxxxxxx>
> > 
> > Both xfs_repair and mkfs.xfs need to agree on what is a "multidisk:
> > configuration - mkfs for determining the AG count of the filesystem,
> > repair for determining how to automatically parallelise it's
> > execution. This requires a bunch of common defines that both mkfs
> > and reapir need to share.
> > 
> > In fact, most of the defines in xfs_mkfs.h could be shared with
> > other programs (i.e. all the defaults mkfs uses) and so it is
> > simplest to move xfs_mkfs.h to the shared include directory and add
> > the new defines to it directly.
> 
> I have to say I do not like making the mkfs header public at all.
> There's things like local prototypes in there that shouldn't be in
> include/, and the name is wrong, too.  include/xfs_geom.h maybe?

Yeah, I know it's a bit messy - I thought that as the series went on
all those prototypes would go away, but only some of them have. I
like the idea of xfs_geom.h, though, because that encapsulates what
we are trying to shared here...

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>