xfs
[Top] [All Lists]

Re: [PATCH 01/15] xfsprogs: use common code for multi-disk detection

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH 01/15] xfsprogs: use common code for multi-disk detection
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Mon, 2 Dec 2013 02:40:16 -0800
Cc: xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <1385689430-10103-2-git-send-email-david@xxxxxxxxxxxxx>
References: <1385689430-10103-1-git-send-email-david@xxxxxxxxxxxxx> <1385689430-10103-2-git-send-email-david@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Fri, Nov 29, 2013 at 12:43:36PM +1100, Dave Chinner wrote:
> From: Dave Chinner <dchinner@xxxxxxxxxx>
> 
> Both xfs_repair and mkfs.xfs need to agree on what is a "multidisk:
> configuration - mkfs for determining the AG count of the filesystem,
> repair for determining how to automatically parallelise it's
> execution. This requires a bunch of common defines that both mkfs
> and reapir need to share.
> 
> In fact, most of the defines in xfs_mkfs.h could be shared with
> other programs (i.e. all the defaults mkfs uses) and so it is
> simplest to move xfs_mkfs.h to the shared include directory and add
> the new defines to it directly.

I have to say I do not like making the mkfs header public at all.
There's things like local prototypes in there that shouldn't be in
include/, and the name is wrong, too.  include/xfs_geom.h maybe?

<Prev in Thread] Current Thread [Next in Thread>