[Top] [All Lists]

Re: [PATCH 0/6] list: introduce list_last_entry_or_null()

To: Jeff Liu <jeff.liu@xxxxxxxxxx>
Subject: Re: [PATCH 0/6] list: introduce list_last_entry_or_null()
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Fri, 15 Nov 2013 06:11:00 -0800
Cc: linux-kernel@xxxxxxxxxxxxxxx, jfs-discussion@xxxxxxxxxxxxxxxxxxxxx, jiri@xxxxxxxxxxx, gregkh@xxxxxxxxxxxxxxxxxxx, oleg@xxxxxxxxxx, "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>, cluster-devel@xxxxxxxxxx, linux-mtd@xxxxxxxxxxxxxxxxxxx, akpm@xxxxxxxxxxxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <5285A33C.4040808@xxxxxxxxxx>
References: <5285A33C.4040808@xxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Fri, Nov 15, 2013 at 12:29:48PM +0800, Jeff Liu wrote:
> Hi Folks,
> This patch is trying to introduce a new list helper to retrieve the
> last entry or return NULL if the list is empty corresponding to it,
> which is inspired by Jiri Pirko's list_first_entry_or_null().

How did we end up with the stupid _or_null prefix there?  I think the
functionality is useful, but the naming is way to verbose, especially
given that a list_first_entry or list_last_entry that optimizes away
that one check doesn't seem useful.

Instead of encoding detailed semantics in the name a good kerneldoc
comment is way better.

<Prev in Thread] Current Thread [Next in Thread>