xfs
[Top] [All Lists]

Re: [PATCH 3/8] xfstests: stat the dev we're removing to make sure its'

To: Eric Sandeen <sandeen@xxxxxxxxxx>
Subject: Re: [PATCH 3/8] xfstests: stat the dev we're removing to make sure its' really gone V2
From: Josef Bacik <jbacik@xxxxxxxxxxxx>
Date: Mon, 21 Oct 2013 11:10:21 -0400
Cc: Josef Bacik <jbacik@xxxxxxxxxxxx>, <linux-btrfs@xxxxxxxxxxxxxxx>, <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/simple; d=fusionio.com; s=default; t=1382368223; bh=7qXCOUqW+JgJAhKCuneuhbn8/BHcJgWVmO/9Rnr9UDc=; h=Date:From:To:CC:Subject:References:In-Reply-To; b=p9yjzjecCxX5+ELPB+4BHPtUTPlwcUpGr9ce/liRAy/VIIYkoj6ulDnid//CLIrlg dB4Loe3NnCC9huavuLD1wQ+YXDW+nabr36jMNLZ3hP5w1qOkGXX+K4PZO7hEdVtnRA iZClWOneUMgU8m2BbwosRAbsV5+9UFlRdRCasu8s=
In-reply-to: <52654329.8050808@xxxxxxxxxx>
References: <1382120790-31060-1-git-send-email-jbacik@xxxxxxxxxxxx> <1382120790-31060-3-git-send-email-jbacik@xxxxxxxxxxxx> <52654329.8050808@xxxxxxxxxx>
User-agent: Mutt/1.5.21 (2011-07-01)
On Mon, Oct 21, 2013 at 10:07:21AM -0500, Eric Sandeen wrote:
> On 10/18/13 1:26 PM, Josef Bacik wrote:
> > I've been periodically failing btrfs/003 because my box sometimes takes a 
> > little
> > longer to unregister the device when we remove it and so the output from 
> > btrfs
> > dev show doesn't match what we are wanting since it still sees the device.  
> > To
> > fix this just stat and sleep if we still see the device node and only 
> > continue
> > once udev or whatever actually removes the device node so that we don't get
> > random failures.  Thanks,
> > 
> > Signed-off-by: Josef Bacik <jbacik@xxxxxxxxxxxx>
> > ---
> > V1->V2: Take Eric's suggestion to do this in the helper function
> > 
> >  common/rc       | 9 +++++++++
> >  tests/btrfs/003 | 2 +-
> >  2 files changed, 10 insertions(+), 1 deletion(-)
> > 
> > diff --git a/common/rc b/common/rc
> > index b253948..253bd05 100644
> > --- a/common/rc
> > +++ b/common/rc
> > @@ -2093,7 +2093,16 @@ _require_freeze()
> >  # ls -l /sys/class/block/sdd | rev | cut -d "/" -f 3 | rev
> >  _devmgt_remove()
> >  {
> > +   local h=$1
> 
> $h is never used?  You use ${1} directly below.  Is that intentional?
> (Not sure if you just meant to eat $1 or if you forgot to replace it
> in the echo string).
> 
> (if you respin, maybe give "$h" a more meaningful name?)
> 

Yeah I screwed up, I'll respin.  Thanks,

Josef

<Prev in Thread] Current Thread [Next in Thread>