xfs
[Top] [All Lists]

Re: prjquota not updating used blocks

To: Ben Myers <bpm@xxxxxxx>
Subject: Re: prjquota not updating used blocks
From: "Weber, Charles (NIH/NIA/IRP) [C]" <WeberC@xxxxxxxxxxxxxxx>
Date: Fri, 9 Aug 2013 14:27:33 -0400
Cc: <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20130809171750.GV1681@xxxxxxx>
References: <6D3CECD5-FBBF-4946-A0D0-5B0C71E772DD@xxxxxxxxxxxxxxx> <20130809151957.GZ3111@xxxxxxx> <C33DFB5C-9524-4D7D-8F9A-8E17088CA20E@xxxxxxxxxxxxxxx> <20130809171750.GV1681@xxxxxxx>
I think I understand it.

I have an existing path on a new server:
/share/niairp/LG
mkdir /share/niairp/LG/NEW
set rights....
# above is normal
copy data from other server
xfsdump... | ssh xfsrestore....

Because I am copying the files from a partition on remote server to a subdirectory on new server via xfsdump and restore, the project tags are not getting applied. The existing files on the other server are xfs but definitely do not have project quotas.
So the solution is to project -s each new dir_name after I do the copy and afterward all should be fine.

I'll try over next week or so to monitor, but it does sound reasonable.
Thanks,
Chuck


Weber, Charles (NIH/NIA/IRP) 
p: 410-558-8001
c: 443-473-6493
251 Bayview Blvd
Baltimore MD 21224
NCTS performance comments and survey at:





On Aug 9, 2013, at 1:17 PM, Ben Myers wrote:

Hey Charles,

On Fri, Aug 09, 2013 at 12:29:20PM -0400, Weber, Charles (NIH/NIA/IRP) [C] wrote:
When I referred to initialize I meant  running xfs_quota -x project -s name

Hmm.  What if you used 'xfs_quota -x project -s -p /path/to/new/dirs name'?

When I run xfs_quota -x 'project -c lg'

I do get warnings about project identifier and inheritance but only for the
new directories that I created and copied the large data sets into. I don't
get those warning about the earlier files and folders for a given project.

Those warnings refer to not having a project id set in the inode core, and
whether a directory will set it's project id into the inode cores of whatever
you create inside.  Without that project id set in the new files you create,
the quota subsystem won't know which project quota to reserve blocks
against.  That's why your block usage wasn't changing.

When I run the project -s again it does update the block usage.

Maybe the first try failed to find the new directory?  I'm not sure.

But I would think the block usage should update automatically.

Could you cut an paste the procedure to you used to create the new directories?

Thanks,
Ben

<Prev in Thread] Current Thread [Next in Thread>