xfs
[Top] [All Lists]

Re: prjquota not updating used blocks

To: Ben Myers <bpm@xxxxxxx>
Subject: Re: prjquota not updating used blocks
From: "Weber, Charles (NIH/NIA/IRP) [C]" <WeberC@xxxxxxxxxxxxxxx>
Date: Fri, 9 Aug 2013 12:29:20 -0400
Cc: <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20130809151957.GZ3111@xxxxxxx>
References: <6D3CECD5-FBBF-4946-A0D0-5B0C71E772DD@xxxxxxxxxxxxxxx> <20130809151957.GZ3111@xxxxxxx>
Hi Ben,
When I referred to initialize I meant  running xfs_quota -x project -s name
When I run xfs_quota -x 'project -c lg'
I do get warnings about project identifier and inheritance but only for the new directories that I created and copied the large data sets into. I don't get those warning about the earlier files and folders for a given project.
When I run the project -s again it does update the block usage. But I would think the block usage should update automatically.
Thanks for replying so quickly.
Chuck


Weber, Charles (NIH/NIA/IRP) 
p: 410-558-8001
c: 443-473-6493
251 Bayview Blvd
Baltimore MD 21224
NCTS performance comments and survey at:





On Aug 9, 2013, at 11:19 AM, Ben Myers wrote:

Hi Charles,

On Fri, Aug 09, 2013 at 10:14:21AM -0400, Weber, Charles (NIH/NIA/IRP) [C] wrote:
CentOS 6.4
Linux niairpfs1.irp.nia.nih.gov 2.6.32-358.6.2.el6.x86_64 #1 SMP Thu May 16 20:59:36 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
xfsprogs-3.1.1-10.el6_4.1.x86_64
xfsdump-3.0.4-3.el6.x86_64

mount
/dev/mapper/shared1_vg-niairp_lv on /share/niairp type xfs (rw,delaylog,inode64,nobarrier,logbsize=256k,uquota,prjquota)

this is a 63T filesystem
xfs_quota report
Project quota on /share/niairp (/dev/mapper/shared1_vg-niairp_lv)
Project ID   Used   Soft   Hard Warn/Grace   
---------- ---------------------------------
lbnnas          0      0     1T  00 [------]
lbnnccu         0      0   4.4T  00 [------]
tgb          1.3T      0     2T  00 [------]
apps       106.4G      0   150G  00 [------]
ncts       205.7G      0   250G  00 [------]
lg           1.4T      0    10T  00 [------]

Since initializing a project quota, there is no change in used blocks. When I initialize the block count is correct.  If I re-initialize, the used block count is updated properly.

I copied 2T last night into the folder referenced by the lg project quota and there is no change in used blocks today.
What have I missed?

An initial guess is you did not set up the project in xfs_quota using the
'project -s' xfs_quota command.

'project -c' output should look like this:

xfs_quota> project -c testproject  
Checking project testproject (path /mnt/test/testa)...
Checking project testproject (path /mnt/test/testb)...
Processed 2 (/etc/projects and cmdline) paths for project testproject with recursion depth infinite (-1).

But if you don't set up a project you might see something like this:

xfs_quota> project -c testproject
Checking project testproject (path /mnt/test/testa)...
/mnt/test/testa - project identifier is not set (inode=0, tree=33)
/mnt/test/testa - project inheritance flag is not set
/mnt/test/testa/file - project identifier is not set (inode=0, tree=33)
/mnt/test/testa/file - project inheritance flag is not set
Checking project testproject (path /mnt/test/testb)...
/mnt/test/testb - project identifier is not set (inode=0, tree=33)
/mnt/test/testb - project inheritance flag is not set
Processed 2 (/etc/projects and cmdline) paths for project testproject with recursion depth infinite (-1).

And you'd have similar symptoms.  You can also check which project the files
you created are in by using the xfs_io 'lsproj' command.  There is also a
'chproj' command if find that your existing files aren't in the project and
need to add them in.

Regards,
Ben

<Prev in Thread] Current Thread [Next in Thread>