xfs
[Top] [All Lists]

Re: [PATCH] xfs: fix an assertion failure

To: xfstests <xfs@xxxxxxxxxxx>
Subject: Re: [PATCH] xfs: fix an assertion failure
From: Zhi Yong Wu <zwu.kernel@xxxxxxxxx>
Date: Wed, 31 Jul 2013 09:32:22 +0800
Cc: Dave Chinner <david@xxxxxxxxxxxxx>, Zhi Yong Wu <wuzhy@xxxxxxxxxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; bh=CT3rqyKfDFGTZiq5yO2XpU5zzRr1X/J6+3LqPdYobrY=; b=xhv/0Sbf7rJd4YaDNxTVdc3wog669AYQMnTJfJX+2W3Hq5LfcHQmXZgj16LhYwiC/W Q7s3kFzZ0BxBHiniw/bf+FoJJ35WJ7gThvLytWBLzf3NaBpIdnn24nSBlIuJkEjrUqOU uRFVh7auSlAQHm5jZRuJz6H3oSlRfKrZ6LzyqpPXEYdNbnq6+NG2z3a7oFfrYBcBsxHe Y7m6DwLpbmzghqEBIrbGE+ArtRKC4w7mKvk3j+cjUftQmcMZejouwwvsBaaBiJeELkn5 scJ3Z26z6wPTXjKS/c51VatOYAfhzbEr/MHuphbn3DLSkYTWSe1wgAKhQexj7C/NkW8s LQiA==
In-reply-to: <51F7BF25.6010103@xxxxxxxxxx>
References: <1374759524-10061-1-git-send-email-zwu.kernel@xxxxxxxxx> <20130726020318.GD21982@dastard> <CAEH94LiXtG=DD+Qn4kbNT_Y_Qn65wVYrpYvHKXOob6wru3SeDw@xxxxxxxxxxxxxx> <20130726113717.GN13468@dastard> <CAEH94Lj27DCzCiWxwerEgwsExtdtviB_+S4bDbxg-wwq445rSA@xxxxxxxxxxxxxx> <CAEH94Lj8FLB-F14hLA880H=OY66vdt1mxjLxwJ9poVSS0xDf8w@xxxxxxxxxxxxxx> <51F7BF25.6010103@xxxxxxxxxx>
On Tue, Jul 30, 2013 at 9:27 PM, Jeff Liu <jeff.liu@xxxxxxxxxx> wrote:
> On 07/30/2013 07:06 PM, Zhi Yong Wu wrote:
>
>> On Mon, Jul 29, 2013 at 4:33 PM, Zhi Yong Wu <zwu.kernel@xxxxxxxxx> wrote:
>>> On Fri, Jul 26, 2013 at 7:37 PM, Dave Chinner <david@xxxxxxxxxxxxx> wrote:
>>>> On Fri, Jul 26, 2013 at 02:01:23PM +0800, Zhi Yong Wu wrote:
>>>>> No, it still raised the same assertion as below:
>>>>>
>>>>> [  521.715103] XFS: Assertion failed: !(bip->bli_item.li_flags &
>>>>> XFS_LI_IN_AIL), file: fs/xfs/xfs_buf_item.c, line: 940
>>>>
>>>> How are you reproducing it?
>>>>
>>>> Can you take an event trace with trace-cmd and attach the output of
>>>> the report?
>>> After kernel base is switched to Linux 3.11-rc3, when i try to take
>>> event trace with trace-cmd, that issue doesn't appear any more in my
>>> environment. :)
>> When your patch is not applied, i hit this issue sometime today, and
>> take some event trace with trace-cmd, and attach it in this mail. But
>> after your patch is applied, i tried some times, but haven't hit so
>> far, so i  want to see if i can hit it in next days.
>
>
> I have ran compilebench multiple times combine with different options against
> xfs-next in the past few days, but I can not reproduce this issue.
I ran it against Linus' tree, and hit this assertion sometimes, not
every time regardless that Dave's patch is applied.
>
> Could you please show us your test case as Dave has asked?  Sometimes, the 
> test
> steps is more useful for someone who has interest in your post.
I just modified the test steps post by Dave.

root@debian-i386:/home/zwu# cat recovery_time_compilebench.sh
#!/bin/bash

i=1
while(($i > 0))
do
    mkfs.xfs -f /dev/sda;
    mount /dev/sda /mnt/scratch
    chmod 777 /mnt/scratch;
    cd ~
    trace-cmd record -e xfs/* &
    cd /home/zwu/compilebench-0.6/
    ./compilebench --no-sync -D /mnt/scratch &
    sleep 55
    /home/zwu/xfstests/src/godown /mnt/scratch
    umount /mnt/scratch
    xfs_logprint -t /dev/sda |head -20
    time mount /dev/sda /mnt/scratch
    umount /mnt/scratch

    sleep 5

    pkill trace-cmd
    rm -rf ~/trace.dat*

    sleep 5
done

>
> Thanks,
> -Jeff



-- 
Regards,

Zhi Yong Wu

<Prev in Thread] Current Thread [Next in Thread>