xfs
[Top] [All Lists]

Re: [PATCH] xfstests: check if the scratch dev pool is mounted in _requi

To: Zach Brown <zab@xxxxxxxxxx>
Subject: Re: [PATCH] xfstests: check if the scratch dev pool is mounted in _require_scratch
From: Josef Bacik <jbacik@xxxxxxxxxxxx>
Date: Wed, 26 Jun 2013 15:34:46 -0400
Cc: Josef Bacik <jbacik@xxxxxxxxxxxx>, <xfs@xxxxxxxxxxx>, <linux-btrfs@xxxxxxxxxxxxxxx>, Eric Sandeen <sandeen@xxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/simple; d=fusionio.com; s=default; t=1372275289; bh=oPw80nDWQkZipkTiUrDUn3FSc94Alz5uotUKp8Q3tcw=; h=Date:From:To:CC:Subject:References:In-Reply-To; b=WXfV0Adqg5aS0xTrHAZw3sjctX8gQfc2d748oSsbk5fU2a9y9wKZu8WF598EfRYdo a8ktQzZte7x8tVb3beS0aq2t/YkphBkR6BmvqvG+WPL5TzZ03mIBzKzUO/Zjpms1UA SsZOMS1vgiBXqD4iF607DSF0eQ0pjFKXvqk/+VNo=
In-reply-to: <20130626191804.GA20692@xxxxxxxxxxxxxxxxxxxx>
References: <1372261768-1795-1-git-send-email-jbacik@xxxxxxxxxxxx> <20130626191804.GA20692@xxxxxxxxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2011-07-01)
On Wed, Jun 26, 2013 at 12:18:04PM -0700, Zach Brown wrote:
> > $SCRATCH_DEV, so anybody who wants to just use the scratch mnt with the 
> > scratch
> > dev will fail to work because we never unmount the scratch mount.
> 
> Yeah, this is annoying.
> 
> > Fix this by
> > checking to see if the scratch dev pool is mounted at scratch mnt and 
> > unmount it
> > so we can run our test.  This fixes the issue I was seeing by running
> 
> But this fix seems bonkers.  Can we have _scratch_unmount unmount the
> mountpoint instead of the device?  That's what Eric suggested when I
> whined about this a while ago.
> 

Well actually we probably need both, since we need callers of _scratch_umount to
actually work.  But my patch is slightly wrong, I need to be making sure the
device is actually mounted at scratch mnt before I unmount it, otherwise error
out.  Thanks,

Josef

<Prev in Thread] Current Thread [Next in Thread>