xfs
[Top] [All Lists]

Re: [PATCH 19/27] xfs: consolidate xfs_vnodeops.c into xfs_inode_ops.c

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH 19/27] xfs: consolidate xfs_vnodeops.c into xfs_inode_ops.c
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Wed, 12 Jun 2013 06:59:16 -0700
Cc: xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <1371032567-21772-20-git-send-email-david@xxxxxxxxxxxxx>
References: <1371032567-21772-1-git-send-email-david@xxxxxxxxxxxxx> <1371032567-21772-20-git-send-email-david@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
I can't say I really like the _ops naming, but so far I can't really
can't come up with a much better name.  I also think that most of
xfs_vnodeops.c really should go into xfs_iops.c as it's fairly Linux
specific and should just be merged with the actual entry points.

Also once the big code move around starts xfs_rename.c really should
die and rename should be treated the same as the other namespace
operations.

<Prev in Thread] Current Thread [Next in Thread>