xfs
[Top] [All Lists]

Re: xfsprogs: is it one issue?

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: xfsprogs: is it one issue?
From: Zhi Yong Wu <zwu.kernel@xxxxxxxxx>
Date: Sun, 26 May 2013 06:46:29 +0800
Cc: xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; bh=udFkxaJ76M1NyLrdYVWlmEGyHnQt1/xOTVWComv1DbE=; b=j+ahgHO19I+LSvA6hkJecrUB1mAFLogZ7tIY+troOH5fPw0Gs4Mytpm9HdOznLxSQI GGU61MqHGyWruJcQaSgJdM8kQGyK/2H5ZmEcE9Dzp7Yk0bYussX4QS6qDeeVGDI/pq7I 0LUDj+0/QyvT9iOi/gqdpdRVpNMrc7TwEJZtfpQCSkLNRcS1shnR7bMhQzA+LKrFGnvN OkTs9hfhQzb4S7sND8Y6tQptHXrDZh/dSdBhfbosFcmA72wWTyq46086csPgaHhbbtiH sSBEnlj/J3Ns6/Q/YOdvPYyfm1NkahVPqRSLAP/zC2s7Ie1LlhIVlWRWYW37p+CNj113 fjWQ==
In-reply-to: <51A1280D.701@xxxxxxxxxxx>
References: <CAEH94LjnVn-uD6cfwOcChC4wq1PppcD8BN30F93SD=YjdTbbuw@xxxxxxxxxxxxxx> <51A1280D.701@xxxxxxxxxxx>
HI,

xfsprogs should be latest, Last year i tried it, and it worked well,
and today pull the latest one and want to replay with it, but fail.
below are the logs on two different boxes:

[root@f15 xfsprogs]# git describe
v3.1.11-8-g8e78288
[root@f15 xfsprogs]# uname -r
3.6.6-rc1+

Also i also tried this on another box:
[root@f17 xfsprogs]# git describe
v3.1.11-8-g8e78288
[root@f17 xfsprogs]# uname -r
3.9.0-rc1+


On Sun, May 26, 2013 at 5:07 AM, Eric Sandeen <sandeen@xxxxxxxxxxx> wrote:
> On 5/25/13 11:29 AM, Zhi Yong Wu wrote:
>> HI,
>>
>> Did anyone hit this issue?
>>
>> [root@f15 xfsprogs]# make
>> Building include
>> Building libxfs
>>     [TEST]    CRC32
>> In file included from ../include/libxfs.h:584:0,
>>                  from crc32.c:36:
>> ../include/xfs/xfs_ialloc.h:75:2: error: unknown type name ‘umode_t’
>> gmake[2]: *** [crc32selftest] Error 1
>> gmake[1]: *** [libxfs] Error 2
>> make: *** [default] Error 2
>
> For starters, which version of xfsprogs?  And what version of kernel headers?
>
> -Eric
>



-- 
Regards,

Zhi Yong Wu

<Prev in Thread] Current Thread [Next in Thread>