xfs
[Top] [All Lists]

Re: XFS assertion from truncate. (3.10-rc2)

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: XFS assertion from truncate. (3.10-rc2)
From: Dave Jones <davej@xxxxxxxxxx>
Date: Wed, 22 May 2013 10:22:52 -0400
Cc: Linux Kernel <linux-kernel@xxxxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20130522055147.GI29466@dastard>
Mail-followup-to: Dave Jones <davej@xxxxxxxxxx>, Dave Chinner <david@xxxxxxxxxxxxx>, Linux Kernel <linux-kernel@xxxxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
References: <20130521234016.GB14347@xxxxxxxxxx> <20130521235410.GY29466@dastard> <20130522000803.GA19891@xxxxxxxxxx> <20130522001603.GZ29466@dastard> <20130522025605.GA29767@xxxxxxxxxx> <20130522040318.GG29466@dastard> <20130522041521.GA1837@xxxxxxxxxx> <20130522051243.GH29466@dastard> <20130522052938.GA2573@xxxxxxxxxx> <20130522055147.GI29466@dastard>
User-agent: Mutt/1.5.21 (2010-09-15)
On Wed, May 22, 2013 at 03:51:47PM +1000, Dave Chinner wrote:

 > > Tomorrow I'll also try running some older kernels with the same
 > > options to see if it's something new, or an older bug. This is a
 > > new machine, so it may be something that's been around for a
 > > while, and for whatever reason, my other machines don't hit
 > > this.
 > 
 > Another thing that just occurred to me - what compiler are you
 > using?  We had a report last week on #xfs that xfsdump was failing
 > with bad checksums because of link time optimisation (LTO) in
 > gcc-4.8.0. When they turned that off, everything worked fine. So if
 > you are using 4.8.0, perhaps trying a different compiler might be a
 > good idea, too.

Yeah, this is 4.8.0. This box is running F19-beta. 
I managed to shoehorn the gcc-4.7 from f18 on there though.
Bug reproduced instantly, so I think we can rule out compiler.

I ran 3.9 with the same debug options. Seems stable.
I'll do a bisect.

        Dave

<Prev in Thread] Current Thread [Next in Thread>