xfs
[Top] [All Lists]

Xfs_repair segfaults.

To: xfs@xxxxxxxxxxx
Subject: Xfs_repair segfaults.
From: Filippo Stenico <filippo.stenico@xxxxxxxxx>
Date: Mon, 6 May 2013 14:06:52 +0200
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=x-received:mime-version:from:date:message-id:subject:to :content-type; bh=jgFxzc0Mk4tXbTNVkem676o8g3Zw9hq//j/3sn+Njlc=; b=XWCWFUYd69Jub+B753p+K/9I3X/vBBD9FYpnIgneG4GNBp/OYNC5nynLE3uhcTzi3E /NRCXno+0V+P3MKXIiyPlAgXThc8zO6Y7gufnV9Kh3tGMY4lPEMxh9r1mIDQjt569iiP xxgAb1Mso19vyEKflMST85QyLEbUAtBzxeF28ZKTgQWfiu/RYIO6NZHx7kFac096A1HH ZzV3hCsYRkANVav3RztBw0ku8lKYnHEELARqHEA0Eu60HGtIEE1Mnn58rUrmgVZ9jw5c SDI/hzpcecwKzR2mbMeh9n2ahhu5btSlB4sfxNw8GHR8Vsgkw71Bfcwl837rz+vDUCzo 9A4g==
Hello,
I've had an issue on a raid5 volume (2 disks failing at same time, and buggy NAS firmware trying hard to sync then stop for I/O error then retryes to sync leading (!?) to lost raid and an xfs data corruption.

I've recreated raid, mounted the xfs filesystem, copied about 6TB of data out of 8TB, the rest of data being unreachable with "structrure needs cleaning" error.
Thus I tried to unmount/mount and still got same error, then dumped metadata and tried various xfs_repair with different options but it always reaches a same point where it always segfaults.

If someone is interested of investigating what's going on here and helping me recover more data I would be happy to send in in more details....

Cheers

--
F
<Prev in Thread] Current Thread [Next in Thread>