xfs
[Top] [All Lists]

Re: xfs module insert fails with "xfs: Unknown symbol exportfs_decode_fh

To: sekharan@xxxxxxxxxx
Subject: Re: xfs module insert fails with "xfs: Unknown symbol exportfs_decode_fh (err 0)"
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Fri, 26 Apr 2013 13:02:37 -0500
Cc: XFS mailing list <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <1366997050.4098.14.camel@xxxxxxxxxxxxxxxxxx>
References: <1366997050.4098.14.camel@xxxxxxxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/20130328 Thunderbird/17.0.5
On 4/26/13 12:24 PM, Chandra Seetharaman wrote:
> Hello,
> 
> When I tried to insert xfs module in my test machine it failed with 
> 
>       xfs: Unknown symbol exportfs_decode_fh (err 0).

so don't use insmod, use modprobe :)

> Found out that I did not have CONFIG_EXPORTFS enabled in my kernel
> config. 

Oh, hum. But fs/xfs/Kconfig:

config XFS_FS
        tristate "XFS filesystem support"
        depends on BLOCK
        select EXPORTFS

it should be turned on automatically.  That seems to be the problem,
why wasn't it for your case?

> All .*by_handle code in XFS is open coded. Wondering if they should be
> under #ifdef CONFIG_EXPORTFS ?

CONFIG_EXPORTFS is supposed to be on if xfs is selected, unless something
changed recently.

-Eric

> I can create a patch, but wanted to find out if it is indeed needed :)
> 
> Regards,
> 
> Chandra
> 
> 
> 
> 
> _______________________________________________
> xfs mailing list
> xfs@xxxxxxxxxxx
> http://oss.sgi.com/mailman/listinfo/xfs
> 

<Prev in Thread] Current Thread [Next in Thread>