xfs
[Top] [All Lists]

Re: Loopback device hung [was Re: xfs deadlock on 3.9-rc5 running xfstes

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: Loopback device hung [was Re: xfs deadlock on 3.9-rc5 running xfstests case #78]
From: Jens Axboe <axboe@xxxxxxxxx>
Date: Wed, 10 Apr 2013 09:24:18 +0200
Cc: Phillip Susi <psusi@xxxxxxxxxx>, CAI Qian <caiqian@xxxxxxxxxx>, xfs@xxxxxxxxxxx, LKML <linux-kernel@xxxxxxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20130409070832.GI17758@dastard>
References: <14055702.547701.1364891947331.JavaMail.root@xxxxxxxxxx> <20130402090047.GF3670@xxxxxxxxx> <985125161.581860.1364895066584.JavaMail.root@xxxxxxxxxx> <20130402094834.GA4667@xxxxxxxxx> <20130403114142.GP4667@xxxxxxxxx> <515C4D9D.10103@xxxxxxxxxx> <515DE2FE.1080201@xxxxxxxxxx> <20130409065519.GH17758@dastard> <20130409070139.GS12244@xxxxxxxxx> <20130409070832.GI17758@dastard>
On Tue, Apr 09 2013, Dave Chinner wrote:
> On Tue, Apr 09, 2013 at 09:01:39AM +0200, Jens Axboe wrote:
> > On Tue, Apr 09 2013, Dave Chinner wrote:
> > > On Thu, Apr 04, 2013 at 04:30:54PM -0400, Phillip Susi wrote:
> > > > > I have not tested it yet, but I am pretty sure it won't work.  It
> > > > > looks like the patch changes the BLKRRPART path to go ahead and remove
> > > > > existing partitions when GENHD_FL_NO_PARTSCAN is set.  loop doesn't
> > > > > issue the BLKRRPART ioctl when !LO_FLAGS_PARTSCAN so this won't help.
> > > > >  I think loop needs to set GENHD_FL_NO_PARTSCAN and then issue the
> > > > > ioctl regardless of the LO_FLAGS_PARTSCAN flag to get the partitions
> > > > > to be removed.  I will try to test tonight.
> > > > 
> > > > After testing, my initial thoughts appeared to have been correct.  I had
> > > > to modify the patch as follows.  To test, simply do:
> > > > 
> > > > truncate -s 10m img
> > > > losetup /dev/loop0 img
> > > > parted /dev/loop0
> > > > mklabel msdos
> > > > mkpart primary ext2 1m 2m
> > > > quit
> > > > ls /dev/loop0*
> > > > 
> > > > Note the /dev/loop0p1 node.  Run losetup -d /dev/loop0 and see if it is
> > > > still there.
> > > 
> > > Jens, can we get one of these fixes merged quickly? xfstests is
> > > unusable on any kernel more recent than 3.9-rc4 because of these
> > > problems....
> > 
> > Yep, did the revert yesterday and it's going out today.
> 
> Great, I didn't see an update in the latest -rc, so I wanted to make
> sure it hadn't fallen through he cracks....

Got pushed out yesterday, it is now upstream.

-- 
Jens Axboe

<Prev in Thread] Current Thread [Next in Thread>