xfs
[Top] [All Lists]

Re: XFS filesystem on EC2 instance corrupts and shuts down

To: Supratik Goswami <supratik.goswami@xxxxxxxxxx>
Subject: Re: XFS filesystem on EC2 instance corrupts and shuts down
From: Ric Wheeler <rwheeler@xxxxxxxxxx>
Date: Wed, 06 Mar 2013 09:25:54 -0500
Cc: Shrinath M <shrinath.m@xxxxxxxxxx>, Sabyasachi Ruj <sabyasachi.ruj@xxxxxxxxxx>, Vivek Goel <vivek.goel@xxxxxxxxxx>, xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <CAOurMUeasru6ekDYcvVR1QnaWVJFV+-coZsUG5SgG6LnENBvXg@xxxxxxxxxxxxxx>
References: <CAOdS1h=7X4O1O7X8YOwxtLm7G=fc+J+6hJxJ1RKbDmfTZXTpeg@xxxxxxxxxxxxxx> <51373DB8.2020707@xxxxxxxxxx> <CAOdS1hnXGj9puaHxeToqmpK40A-3WvJnM7=5HckpyyZYqZTvEQ@xxxxxxxxxxxxxx> <51373FC1.6010101@xxxxxxxxxx> <CAOurMUeasru6ekDYcvVR1QnaWVJFV+-coZsUG5SgG6LnENBvXg@xxxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130219 Thunderbird/17.0.3
I would suggest contacting Amazon's customer support channel (or the vendor you paid for the Linux instance you are running).

XFS developer list is probably not the correct forum to help you debug this :)

Good luck!

Ric


On 03/06/2013 08:12 AM, Supratik Goswami wrote:
Have we created a ticket with AWS ?

It could be an EBS issue who knows, we need to confirm that first.

--
Warm Regards

Supratik


On Wed, Mar 6, 2013 at 6:38 PM, Ric Wheeler <rwheeler@xxxxxxxxxx <mailto:rwheeler@xxxxxxxxxx>> wrote:

    On 03/06/2013 08:03 AM, Shrinath M wrote:


        On Wed, Mar 6, 2013 at 6:29 PM, Ric Wheeler <rwheeler@xxxxxxxxxx
        <mailto:rwheeler@xxxxxxxxxx> <mailto:rwheeler@xxxxxxxxxx
        <mailto:rwheeler@xxxxxxxxxx>>> wrote:

            I think that you would need to verify that the Amazon storage is not
            throwing errors - do your logs show IO errors or issues before XFS
        hits an
            issue?


        No IO errors in /var/log/messages.
        Where else should I be looking?



    Feb 12 19:47:18 ip-100-0-100-1 kernel: [2541168.023638] XFS (md0): I/O
    Error Detected. Shutting down filesystem

    Is an IO error from MD.

    I would suggest trying to reproduce without MD in the picture first -
    always best to try to reproduce with the simplest setup first and work
    your way up the complexity ladder,

    Ric




_______________________________________________
xfs mailing list
xfs@xxxxxxxxxxx
http://oss.sgi.com/mailman/listinfo/xfs

<Prev in Thread] Current Thread [Next in Thread>