xfs
[Top] [All Lists]

Re: [PATCH] xfstests 276: fix error 'FIBMAP: Invalid argument'

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH] xfstests 276: fix error 'FIBMAP: Invalid argument'
From: Wang Sheng-Hui <shhuiw@xxxxxxxxx>
Date: Thu, 28 Feb 2013 08:02:52 +0800
Cc: xfstests <xfs@xxxxxxxxxxx>, linux-btrfs@xxxxxxxxxxxxxxx, list.btrfs@xxxxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=x-received:message-id:date:from:user-agent:mime-version:to:cc :subject:references:in-reply-to:content-type :content-transfer-encoding; bh=bIfqek/v9iPOvquyzgxwqwaAQ8IrsFTil+VpDbjJjQA=; b=i9k7reqPXQ2V4pJXXmVhlus/+NplTxNwXqbme5ciaZ3ZiVoLaktEIXAi0XlLY9yfb1 N3PIK9jYQKXBYwTUI4WkIaYCwC0t0y0n5SStS+jme1V1iO3VKsuH1v4ETuLLG2ZtQ1z2 6LBVbz3GRiLlBbVNP+jrKvBtHuS5BnTvGkvJlMXF95R2k9dtEr2V/n3PqPz1lm2aFxjE zTz5xbub8Gmrlykfj0Q8gT2fH2QKLiunTooiIlR4GacOL/paxOEJWj0ig7ncSNtTwZ8Y Y3zWa6H4qsDY5z5WC39Urcl+8t2TSGZjTHciTNIBhT9SBvWyNF5K1BEMkv2I/OADTO4m 9fKQ==
In-reply-to: <20130227230443.GB5551@dastard>
References: <512DB284.1090806@xxxxxxxxx> <20130227230443.GB5551@dastard>
User-agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Thunderbird/17.0
On 2013å02æ28æ 07:04, Dave Chinner wrote:
On Wed, Feb 27, 2013 at 03:15:16PM +0800, Wang Sheng-Hui wrote:
Btrfs doesn't support FIEMAP_FLAG_XATTR, which is enabled by
-x option of filefrag, and will fail with
        'FIBMAP: Invalid argument'
for 'filefrag -vx'. 'filefrag -vx' fails on btrfs with
     'FIEMAP failed with unsupported flags 2'
Remove the '-x' option.

Signed-off-by: Wang Sheng-Hui <shhuiw@xxxxxxxxx>

I can see that this changes what gets dumped into the $seq.full
file, but it seems to me that also changes the extent list returned
to the checking functions. So either the test previously worked and
now it fails with this change, or the test never worked and now it
does, or perhaps something else?

IOWs, I can't tell why you want to change this from the patch
description, hence I don't know if the original behaviour was
intentional or not.  Can you say describe what the overall effect of
the change is in the commit description?

Hi Dave,

I run xfstests for btrfs against SLES11SP2, not upstream kernel.
In the seq.full, I can get the messages
        'FIEMAP failed with unsupported flags 2'

Then I found that the test will run 'filefrag -vx' on btrfs, and
'-v' will run FIEMAP_FLAG_XATTR, which is not supported by btrfs
yet, at least in 3.8 kernel.

Without the patch, I failed the testcase and got:
=============================================
276 8s ... - output mismatch (see 276.out.bad)
    --- 276.out 2013-02-25 19:08:58.000000000 -0600
    +++ 276.out.bad     2013-02-27 17:59:48.000000000 -0600
    @@ -1,4 +1,867 @@
     QA output created by 276
     *** test backref walking
    +FIBMAP: Invalid argument
    +FIBMAP: Invalid argument
    +FIBMAP: Invalid argument
    +FIBMAP: Invalid argument
    +FIBMAP: Invalid argument
     ...
     (Run 'diff -u 276.out 276.out.bad' to see the entire diff)
Ran: 276
Failures: 276
Failed 1 of 1 tests

In the 276.full, I got something like:
=============================================
# filefrag -vx /mnt/scratch/snap1/p0/d4/d21/d4a/f58
Filesystem type is: 9123683e
File size of /mnt/scratch/snap1/p0/d4/d21/d4a/f58 is 2125615 (33 blocks, 
blocksize 65536)
FIEMAP failed with unsupported flags 2


With the patch, I can pass the testcase:
=============================================
276 8s ... 7s
Ran: 276
Passed all 1 tests



Cheers,

Dave.


<Prev in Thread] Current Thread [Next in Thread>