xfs
[Top] [All Lists]

Re: problem after growing

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: problem after growing
From: Rémi Cailletaud <remi.cailletaud@xxxxxxxxxxxxxxx>
Date: Wed, 13 Feb 2013 19:09:49 +0100
Cc: xfs-oss <xfs@xxxxxxxxxxx>
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <511BD2D1.9010906@xxxxxxxxxxx>
References: <511BC78B.6070205@xxxxxxxxxxxxxxx> <511BCB41.4060804@xxxxxxxxxxx> <511BCD11.20907@xxxxxxxxxxxxxxx> <511BCFB6.8000309@xxxxxxxxxxx> <511BD0FB.2070401@xxxxxxxxxxxxxxx> <511BD2D1.9010906@xxxxxxxxxxx>
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.12) Gecko/20130116 Icedove/10.0.12
Le 13/02/2013 18:52, Eric Sandeen a écrit :
On 2/13/13 11:44 AM, Rémi Cailletaud wrote:
Le 13/02/2013 18:39, Eric Sandeen a écrit :
On 2/13/13 11:27 AM, Rémi Cailletaud wrote:
Le 13/02/2013 18:20, Eric Sandeen a écrit :
On 2/13/13 11:04 AM, Rémi Cailletaud wrote:
Hi,

I face a strange and scary issue. I just grow a xfs filesystem (44To), and no 
way to mount it anymore :
XFS: device supports only 4096 byte sectors (not 512)
Did you expand an LV made of 512-sector physical devices by adding 4k-sector 
physical devices?
The three devices are ARECA 1880 card, but the last one was added later, and I 
never check for sector physical configuration on card configuration.
But yes, running fdisk, it seems that sda and sdb are 512, and sdc is 4k... :(

that's probably not something we anticipate or check for....

What sector size(s) are the actual lowest level disks under all the lvm pieces?
(re-cc'ing xfs list)

What command to run to get this info ?
IIRC,

# blockdev --getpbsz --getss  /dev/sda

to print the physical&   logical sector size

You can also look at i.e.:
/sys/block/sda/queue/hw_sector_size
/sys/block/sda/queue/physical_block_size
/sys/block/sda/queue/logical_block_size
ouch... nice guess :
#  blockdev --getpbsz --getss  /dev/sda
512
512
#  blockdev --getpbsz --getss  /dev/sdb
512
512
#  blockdev --getpbsz --getss  /dev/sdc
4096
4096


I wonder what the recovery steps would be here.  I wouldn't do anything yet; I 
wish you hadn't already cleared the log, but oh well.
I tried a xfs_repair -L (as mentionned by xfs_check), but it early failed as 
show on my first post...
Ah, right.

So you grew it, that all worked ok, you were able to copy new data into the new 
space, you unmounted it, but now it won't mount, correct?
I never was able to copy data to new space. I had an input/output error just 
after growing.
may pmove-ing extents on 4k device on a 512k device be a solution ?
Did the filesystem grow actually work?

# xfs_db -c "sb 0" -c "p" /dev/vg0/tomo-201111
magicnum = 0x58465342
blocksize = 4096
dblocks = 10468982745

That looks like it's (still?) a 38TiB/42TB filesystem, with:

sectsize = 512

512 sectors.

How big was it before you tried to grow it, and how much did you try to grow it 
by?  Maybe the size never changed.

Was 39, growing to 44. Testdisk says 48 TB / 44 TiB... There is some chance that it was never really growed.
At mount time it tries to set the sector size of the device; its' a hard-4k 
device, so setting it to 512 fails.

This may be as much of an LVM issue as anything; how do you get the LVM device 
back to something with 512-byte logical sectors?  I have no idea...

*if* the fs didn't actually grow, and if the new 4k-sector space is not used by 
the filesystem, and if you can somehow remove that new space from the device 
and set the LV back to 512 sectors, you might be in good shape.
I dont either know how to see nor set LV sector size. It's 100% sure that anything was copied on 4k sector size, and pretty sure that the fs did not really grow.

Proceed with extreme caution here, I wouldn't start just trying random things 
unless you have some other way to get your data back (backups?).  I'd check 
with LVM folks as well, and maybe see if dchinner or the sgi folks have other 
suggestions.
Sigh... No backup (44To is too large for us...) ! I'm running a testdisk recover, but I'm not very confident about success...
Thanks to deeper investigate this...
First let's find out if the filesystem actually thinks it's living on the new 
space.
What is the way to make it talk about that ?

Thanks again for your help !

rémi

-Eric

rémi

_______________________________________________
xfs mailing list
xfs@xxxxxxxxxxx
http://oss.sgi.com/mailman/listinfo/xfs



--
Rémi Cailletaud - IE CNRS
3SR - Laboratoire Sols, Solides, Structures - Risques
BP53, 38041 Grenoble CEDEX 0
FRANCE
remi.cailletaud@xxxxxxxxxxxxxxx
Tél: +33 (0)4 76 82 52 78
Fax: +33 (0)4 76 82 70 43



<Prev in Thread] Current Thread [Next in Thread>